Home Page

v. 2.0.0
21/01/2018
NickServ | ChanServ
MemoServ | BotServ
SeenServ | HostServ
Statistiche | Modes
Varie

Copyright © 2012-2018 GlobalIRC Network All rights reserved.

Autore originale TuSaiChi

Per la realizzazione si ringrazia: [Mr][GeFFeRsON] e tutti i componenti dello staff
Per segnalazione su eventuali correzioni, potete utilizzare
il forum all'indirizzo https://www.globalforum.globalirc.it
oppure potete inviare una e-mail all'indirizzo staff@globalirc.it .

IMPORTANTE: Nei comandi non dovranno mai essere usate le parentesi quadre, che racchiudono un parametro opzionale. Le opzioni separate dal carattere | (ad esempio ON|OFF) indicano che si dovrà scrivere ON oppure OFF.

Le parti di comando indicate in MAIUSCOLO, così come /msg NickServ, /msg ChanServ ecc., non devono essere modificate.

È possibile abbreviare i comandi /msg NickServ, /msg ChanServ, /msg MemoServ, /msg SeenServ, con i comandi /NickServ, /ChanServ, /MemoServ, /SeenServ, oppure con i comandi /ns, /cs, /ms, /hs rispettivamente, ottenendo lo stesso identico risultato a meno di problemi specifici del client o dello script usato.

Nel caso che il comando abbreviato dia risultati inattesi o incomprensibili è consigliabile usare il comando esteso.


Nickserv

I Comandi di NickServ
NickServ permette a chiunque di registrare il proprio nickname, il che assicura che esso potrà essere utilizzato solo ed esclusivamente dal suo proprietario mediante l'inserimento di una password scelta al momento della registrazione.

I nickname a cui non viene effettuato accesso per un periodo di 60 giorni (con identificazione) sono automaticamente cancellati dal sistema.

Un nickname registrato può essere nelle liste come Fondatore Owner, Protect, SOP, AOP, HOP, VOP.
  • ACCESS - Modifica la lista degli indirizzi autorizzati
  • AJOIN - Mantiene la lista AutoJoin nei canali, per i nick Gruppati
  • ALIST - Mostra i canali in cui si ha accesso
  • CERT - Modifica la lista dei certificati del client il nickname
  • CONFIRM - Conferma un "auth code" di nickserv
  • DROP - Annulla la registrazione del nick
  • GLIST - Mostra la lista di tutti i nick nel proprio gruppo
  • GROUP - Entra in un gruppo
  • HELP - Help on-line di NickServ
  • IDENTIFY - Identifica come possessore del nickname
  • INFO - Informazioni su un nickname registrato
  • LIST - Mostra l'elenco dei nick registrati corrispondenti la chiave specificata
  • LOGOUT - Deidentifica dal proprio nick
  • RECOVER - Scollega qualcuno che stia usando il nickname
  • REGISTER - Registra il nickname
  • RESEND - Reinvia un "auth code" di nickserv
  • RESETPASS - Avvia la procedura per reimpostare le passwords perdute
  • SET - Imposta vari parametri
  • STATUS - Indica lo stato di identificazione di un nick
  • UNGROUP - Rimuove un nick da un gruppo
  • UPDATE - Aggiorna il tuo stato attuale, ovvero controlla eventuali nuovi memo

Per maggiori informazioni, una volta connessi alla rete IRC, digitare: /msg NickServ HELP


ACCESS

NickServ - ACCESS

Visualizza o modifica la lista di accesso per il tuo nick. Si tratta della lista degli indirizzi che saranno riconosciuti automaticamente da NickServ e che ti permetteranno di utilizzare il tuo nick. Se vuoi usare il nick da indirizzi diversi, dovrai utilizzare il comando IDENTIFY per farti riconoscere da NickServ.

È necessario identificarsi prima di poter usare questo comando.

Sintassi:
/msg NickServ ACCESS ADD user@host
/msg NickServ ACCESS DEL user@host
/msg NickServ ACCESS LIST

ADD aggiunge una mask alla Access list.

DEL cancella una mask dalla Access list.

LIST visualizza le mask presenti nella Access list.

Esempi:
/msg NickServ ACCESS ADD capoz@*.aruba.it
/msg NickServ ACCESS DEL manu@*.jnet.it
/msg NickServ ACCESS LIST
Per problemi nel determinare le maschere, consultare la sezione Maschere di riconoscimento o rivolgersi ad un operatore su #IRCHelp.


AJOIN

NickServ - UPDATE

Mantiene la lista autojoin per i nick gruppati. Se un utente si identifica al suo nickname,
lo farà entrare automaticamente i canali inseriti in questa lista.

Adesso vediamo i comandi disponibili:

AJOIN { ADD | DEL | LIST } [ nickname | #canale ] [ key ]

Il comando AJOIN ADD aggiunge il canale specificato alla lista autojoin o aggiorna la voce esistente, se è giá presente sulla lista autojoin. Se nessun tasto viene dato e una voce per il canale è già presente, il set giá chiave (se presente) viene disinserito. Solo i canali registrati sono accettati!

Il comando AJOIN DEL rimuove il canale indicato dalla lista autojoin. Se viene indicata una lista di numeri, verrano rimossi i record.

Il comando AJOIN LIST mostra la lista autojoin. Se viene usata una wildcard, vengono visualizzati solo i record che corrispondono alla mask. Se viene indicata una lista di numeri, vengono visualizzati solo i record.

Sintassi:
/msg NickServ ADD nickname #canale key
 /msg NickServ DEL nickname #canale
/msg NickServ LIST nickname


ALIST

NickServ - ALIST
M ostra tutti i canali su cui hai accesso. La lista risultante includerà soltanto i canali su cui hai il livello di accesso indicato o superiore.
I canali che hanno l'opzione NOEXPIRE impostata verranno mostrati con un punto esclamativo.
E' necessario essere identificati per usare questo comando.
Sintassi:
/msg NickServ ALIST nickname
N.B. = Il parametro nick è limitato ai Services Operators


CONFIRM

NickServ - CONFIRM
Questa è la seconda fase del processo di registrazione del nick.

È necessario eseguire questo comando al fine di ottenere il tuo nickname registrato con NickServ. Il codice di accesso (o chiamato anche codice di autorizzazione) viene inviato al vostro indirizzo e-mail nella prima fase del processo di registrazione. Per ulteriori informazioni sul primo fase del processo di registrazione, digitare: / msg NickServ HELP REGISTER
E' usato anche dopo il comando RESETPASS per forzare l' identificazione del tuo nick e permetterti di reimpostare la password.
Sintassi:
/msg NickServ CONFIRM passcode
Esempio:
/msg NickServ CONFIRM ZAxKzjCs8


CERT

NickServ - CERT
Modifica o visualizza l'elenco dei certificati per il tuo nick.
Se ci si connette a IRC e si fornisce un certificato client con l'impronta digitale corrispondente nell'elenco dei certificati, lo sarai
automaticamente identificato ai servizi.
L'Operatori dei servizi può fornire un nick per modificare gli elenchi di certificati di altri utenti.
Sintassi:
/msg NickServ CERT ADD nickname fingerprint
/msg NickServ CERT DEL nickname fingerprint
/msg NickServ CERT LIST
Esempio:
/msg NickServ CERT ADD pippo 43:51:43:a1:b5:fc:8b:b7:0a:3a:a9:b1:0f:66:73:a8
Aggiunge l'impronta digitale corrente all'elenco dei certificati e identifica automaticamente quando ti connetti a IRC usando questa impronta digitale.
/msg NickServ CERT DEL pippo 43:51:43:a1:b5:fc:8b:b7:0a:3a:a9:b1:0f:66:73:a8
Rimuove l'impronta digitale 43:51:43:a1:b5:fc:8b:b7:0a:3a:a9:b1:0f:66:73:a8 dall'elenco dei certificati.
/msg NickServ CERT LIST
Visualizza l'elenco di certificati corrente.


DROP

NickServ - DROP
Con questo comando si cancella la registrazione del nickname specificato: ciò significa che esso tornerà disponibile a tutti gli utenti. Verranno inoltre droppati tutti i canali in cui il nick risulta founder, se non è stato impostato un altro QOP o OWNER . È necessario essere identificati (con il comando IDENTIFY) per il nickname che si desidera cancellare prima di utilizzare questo comando.

Sintassi:
/msg NickServ DROP nickname
Esempi:
/msg NickServ DROP mirtilla86


GLIST

NickServ - GLIST
Questo comando, mostra tutti i nick presenti nel tuo gruppo.
Sintassi:
/msg NickServ GLIST


GROUP

NickServ - GROUP
Questo comando fa sì che il tuo nick entri nel gruppo del nick destinazione. Password è la password del nick di destinazione.
Entrare in un gruppo ti permetterà di condividere la tua configurazione, i tuoi memo e i privilegi sui canali con tutti i nick nel tuo gruppo.
Un gruppo esiste fino a quando è utile. Questo significa che anche se uno dei nick del gruppo viene deregistrato, non perderai le condivisioni descritte sopra, fino a quando nel gruppo resta almeno un nick.
Puoi usare questo comando anche se non hai ancora registrato il tuo nick. Se il tuo nick è già registrato, dovrai identificarti prima di usare questo comando. Digita /msg NickServ HELP IDENTIFY per maggiori informazioni.
E' consigliato l'uso di questo comando con un nick non registrato, in quanto verrà registrato automaticamente con l'uso stesso di questo comando.
E' possibile stare in un solo nick per volta. L'unione dei gruppi non è possibile.
Sintassi:
/msg NickServ GROUP [target] [password]
Nota: tutti i nick di un gruppo hanno la stessa password.


HELP

NickServ - HELP
È il comando per ottenere help on-line sul servizio NickServ.

Sintassi:
/msg NickServ HELP [comando]
Esempi:
/msg NickServ HELP
/msg NickServ HELP REGISTER
/msg NickServ HELP ALIST


IDENTIFY

NickServ – IDENTIFY
Questo comando permette di fornire a NickServ la password per il nickname che si sta utilizzando. Ciò è necessario per identificarsi come proprietari del nickname correntemente in uso.

È possibile anche identificarsi ad un nick pur utilizzandone un altro. In questo modo è possibile essere oppati da Chanserv nei canali di cui si è nelle liste.

Non c’è un limite di nick a cui si può essere identificati contemporaneamente. Ad esempio, se si hanno due nick registrati, è possibile identificarsi ad entrambi e quindi avere accesso ai comandi di ChanServ per tutti i canali di cui si è nelle liste con almeno uno dei due nick.

Sintassi:
/msg NickServ IDENTIFY [account] password

Esempi:
/msg NickServ IDENTIFY pippo 12345


INFO

NickServ - INFO
Utilizzando questo comando si ottengono informazioni ulteriori su un nickname registrato, come il proprietario del nick, la data di registrazione o l'ultima volta che è stato utilizzato.
Se non viene specificato il nick, e sei identificato, viene usato il tuo nome account, altrimenti sarà usato il tuo nickname in uso.

Sintassi:
/msg NickServ INFO nickname
Esempio:
/msg NickServ INFO ^Norad^
/msg NickServ INFO ^Norad^ ALL


LIST

NickServ - List

Mostra tutti i nick registrati che corrispondono al pattern specificato, nel formato nick!user@hostnick!user@host.
I nick con l'opzione PRIVATE attiva saranno mostrati solo ai Services Operator. I nick con l'opzione NOEXPIRE attiva avranno un ! prima del nick stesso (solo per i Services Operator).

Nota che l' uso del carattere '#' specifica un range.

Se sono specificate le opzioni SUSPENDED, NOEXPIRE o UNCONFIRMED, unicamente i nick che sono rispettivamente SUSPENDED, UNCONFIRMED oppure hanno la flag NOEXPIRE impostata verranno mostrati.

Se tutte e tre le opzioni sono specificate, tutti e tre i tipi di nick verranno mostrati. Queste opzioni sono limitate ai Services Operator.

Sintassi:
/msg NickServ LIST pattern [SUSPENDED] [NOEXPIRE] [UNCONFIRMED]

Esempio:
/msg NickServ LIST *!joeuser@foo.com
Mostra tutti i nick che appartengono a joeuser@foo.com.

/msg NickServ LIST *Bot*!*@*
Mostra tutti i nick registrati che contengono Bot (case insensitive).

/msg NickServ LIST * NOEXPIRE
Mostra tutti i nick registrati che sono stati impostati per non scadere.

/msg NickServ LIST #51 100
Mostra tutti i canali registrati compresi nel range specificato (51 100).

E' supportato l' uso di espressioni regolari utilizzando il motore regex/pcre.

Se vuoi puoi includere la mask tra //.


LOGOUT

NickServ - LOGOUT

Annulla l'effetto del comando IDENTIFY, cioè fa in modo che tu non sia più riconosciuto come il vero proprietario del nick. Tieni presente, però, che non dovrai identificarti di nuovo.
Sintassi:
/msg NickServ LOGOUT


RECOVER

NickServ - RECOVER
Questo comando permette di recuperare immediatamente il proprio nick se risulta in uso da parte di un altro utente. NickServ cambia il nick dell’utente in questione in GuestXXXXX, cosa che farebbe automaticamente se l'opzione KILL fosse attiva. Per poter utilizzare questo comando è necessario conoscere la password del nick che si vuole recuperare.
Sintassi:
/msg NickServ RECOVER nickname password
Esempio:
/msg NickServ RECOVER Casper 12AB56cd


REGISTER

NickServ - REGISTER
Questo è il comando da utilizzare per registrare il proprio nickname.

Registrare un nick permette di sfruttare a pieno il servizio NickServ. Risulta possibile, fra le altre cose, recuperare immediatamente il proprio nick nel caso risultasse in uso da parte di altri, registrare canali, inviare memo etc.

Al momento della registrazione viene inviata una E-Mail contenente un codice di autorizzazione che deve essere inserito, entro 24 ore, per confermare la registrazione del nick. Le istruzioni al riguardo sono contenute nella E-Mail stessa. I nick non autorizzati entro 24 ore scadono.

Il nick viene settato con il mode +r solo dopo l’autorizzazione.
La password deve essere una stringa di un numero di caratteri compreso tra 5 e 32, senza codici di controllo e spazi, e non può essere uguale al nick per motivi di sicurezza. È inoltre sconsigliato usare come password il proprio nome, in quanto spesso troppo facile da indovinare. Infine, gli spazi non
possono essere usati all'interno di una password.
È ovviamente indispensabile che l’indirizzo E-mail sia valido al momento della registrazione, per poter ricevere il codice di autorizzazione.
L'indirizzo E-Mail è necessario sia per lo staff, per riconoscerti o contattarti in caso di bisogno, sia per te, nel caso ti dimenticassi la password del tuo nick o di un canale di cui sei Founder e la richiedessi in mail.
Q uesto comando crea anche un nuovo gruppo per il tuo nick, che ti permetterÃ di registrare altri nick condividendo la stessa configurazione, gli stessi memo e gli stessi privilegi sui canali.

La registrazione di un nick può essere cancellata mediante il comando DROP.

Sintassi:
/msg NickServ REGISTER password email
Esempi:
/msg NickServ REGISTER pippo pippo@email.it


RESEND

NickServ - RESEND
Questo comando serve per inviare nuovamente il codice di autorizzazione (anche chiamato codice di accesso) alla e-mail dell'utente che lo sta eseguendo.
E' necessario essere identificati per usare questo comando.
Sintassi:
/msg NickServ Resend


RESETPASS

NickServ - ResetPass

Invia un messaggio contenente un codice di attivazione e le istruzioni necessarie per procedere al reset della password per il nickname specificato.
L' indirizzo email deve corrispondere all' indirizzo email associato al nickname.

Sintassi:
/msg NickServ RESETPASS nickname e-mail


SET

NickServ - SET
Questo comando permette di settare varie opzioni o attivare particolari funzioni per la gestione del proprio nickname.
  • AUTOOP Imposta se i service imposteranno automaticamente il tuo stato nei canali.
    Imposta se i service imposteranno automaticamente il tuo stato nei canali.
    Imposta su ON per permettere a ChanServ di impostare automaticamente il tuo stato
    quando accedi ai canali. Nota che a seconda delle impostazioni del canale
    alcuni modi potrebbero non essere impostati automaticamente.
    Sintassi: /msg NickServ SET AUTOOP { ON|OFF }
  • CHANSTATS Attiva o disattiva le statistiche chanstats
    Attiva o disattiva le statistiche di Chanstats.
    Sintassi:     /msg NickServ SET CHANSTATS {ON | OFF}
  • DISPLAY Imposta il nome del tuo gruppo.
    Imposta il nome con cui i Services si riferiscono al tuo gruppo. Il nuovo nome DEVE essere un nick del gruppo.
    Sintassi:     /msg NickServ SET DISPLAY nuovo-nome
  • EMAIL - Permette di gestire l’indirizzo E-mail associato al proprio nick.
    Associa l'indirizzo e-mail specificato al proprio nick. Questo indirizzo sarà mostrato quando qualcuno richiede informazioni sul proprio nick con il comando INFO.

    S    intassi: /msg NickServ SET EMAIL nuovo_indirizzo@email
    Esempio: /msg NickServ SET email indirizzoemail@host.it
  • FACEBOOK Associa un URL Facebook con il tuo profilo
    Associa il tuo URL del profilo di FACEBOOK, al tuo account.
    Sintassi: /msg NickServ SET FACEBOOK https://www.facebook.com/GlobalIRCNetwork
  • GREET Associa un messaggio di saluto al tuo nick
    Imposta come saluto del tuo nick il messaggio specificato, che sarà mostrato quando si entra in un canale che ha l'opzione GREET attiva, se si ha un livello di accesso al canale sufficiente.

    Sintassi: /msg NickServ SET GREET messaggio
  • HIDE Nasconde alcune informazioni sul tuo nick
    Ti permette di nascondere alcune informazioni quando qualcuno effettua un NickServ INFO sul tuo nick. Puoi nascondere il tuo indirizzo e-mail (EMAIL), l'ultima hostmask di accesso (USERMASK) e l'ultimo messaggio di quit (QUIT). Il secondo parametro specifica se l'informazione indicata debba essere mostrata (OFF) o nascosta (ON).

    Sintassi: /msg NickServ SET HIDE {EMAIL | USERMASK | QUIT} {ON | OFF}
  • ICQ Associa un numero ICQ al tuo nick
    Associa il numero ICQ specificato al proprio nick. Questo indirizzo sarà mostrato quando qualcuno richiede informazioni sul proprio nick con il comando INFO.

    Sintassi: /msg NickServ SET ICQ numero
  • KEEPMODES Abilita o disabilita il mantenimento degli user mode
    Abilita o disabilita il mantenimento dei modi per il tuo nick.
    Se il mantenimento dei modi Ã¨ abilitato, i services memorizzeranno
    i tuoi usermodes, e provvederanno a reimpostarli la prossima volta
    che ti autenticherai.
    Sintassi:     /msg NickServ SET KEEPMODES {ON | OFF}
  • KILL Attiva o disattiva la protezione
    Attiva o disattiva l'opzione di protezione automatica per il tuo nick. Quando la protezione è attiva, se un altro utente cerca di usare il tuo nick, avrà un minuto per cambiarlo, dopo del quale NickServ gli assegnerà un nick casuale.

    Se scegli QUICK, l'utente avrà soltanto 20 secondi per cambiare nick invece di 60. Se scegli IMMED, il nick sarà cambiato immediatamente, senza essere prima avvisato per dargli la possibilità di cambiare nick; non usare questa opzione se non è strettamente necessario. L'opzione IMMED, inoltre, potrebbe non essere disponibile.

    Sintassi: /msg NickServ SET KILL {ON | QUICK | IMMED | OFF}
  • LANGUAGE Imposta la lingua utilizzata dai Services
    Cambia la lingua utilizzata dai Services per inviarti
    i messaggi, ad esempio per rispondere a un comando che
    tu invii.
    La lingua può essere scelta dalla seguente lista di
    lingue supportate:
    en_US (English)
    it_IT.UTF-8 (Italiano)
  • Sintassi:
    /msg NickServ SET LANGUAGE parametro

    Esempio per scegliere la lingua in Italiano:
    /msg NickServ SET LANGUAGE it_IT.UTF-8
  • MESSAGE Cambia il metodo di comunicazione usato dai Services
    Ti permette di scegliere il modo in cui i Services comunicano con te. Se MSG è attivo, i Services usano i messaggi (query), altrimenti usano i notices.

    Sintassi:
    /msg NickServ SET MSG { ON | OFF }
  • PASSWORD - Permette di cambiare la password del nick che stai usando al momento in cui usi il comando.

    Sintassi:
    /msg NickServ SET PASSWD vecchia_pass nuova_pass

    Esempio:
    /msg NickServ SET PASSWD 030574 ab98df3DD4
  • PRIVATE Nasconde il nick dalla lista (/msg NickServ LIST)
    Attiva o disattiva l'opzione privacy di NickServ per il tuo nick. Quando PRIVATE è attivo, il tuo nick non comparirà nelle liste dei nick generate con NickServ comando LIST. In ogni caso, però, chiunque sappia il tuo nick può leggerne le informazioni con il comando INFO.

    Sintassi:
    /msg NickServ SET PRIVATE { ON | OFF }
  • SECURE - Attiva l'opzione Secure per il tuo nick.
    Attiva o disattiva sul tuo nick le funzionalità di sicurezza di NickServ. Quando SECURE è attivo, devi identificarti come proprietario del nick, anche se il tuo indirizzo compare nella lista di accesso. Comunque, se sei nella lista di accesso, NickServ non cambierà il tuo nick, anche se l'opzione KILL è attiva.

     Sintassi: /msg NickServ SET SECURE { ON | OFF }
  • TWITTER Associa un profilo Twitter al tuo account
    Associa il tuo URL del profilo di TWITTER al tuo account.
    Sintassi: /msg NickServ SET TWITTER https://twitter.com/GlobalIRCNetwork
  • URL - Permette di associare un URL al nick specificato.
    Questo URL è quello che risulterà ad ogni utente che richieda le informazioni del nick tramite il comando INFO.
    Per rimuovere l'URL corrente bisogna specificare NONE come indirizzo.
    Sintassi: /msg NickServ SET URL indirizzo

    Esempio: /msg NickServ SET URL http://www.garzantilinguistica.it/

IMPORTANTE: Per usare questo comando, devi prima identificarti con la tua password (digita /msg NickServ HELP IDENTIFY per ottenere maggiori informazioni).

Digita /msg NickServ HELP SET opzione per avere maggiori informazioni su una opzione specifica.


STATUS

NickServ - STATUS

Indica se l'utente che usa il nick specificato è riconosciuto come proprietario del nick. La risposta ha questo formato:

nick codice-di-stato

dove nick è il nick inviato con il comando, e codice-di-stato può essere:

0 - l'utente non è online o il nick non è registrato;
1 - l'utente non è riconosciuto come proprietario del nick;
2 - l'utente è riconosciuto come proprietario solo attraverso la lista di accesso;
3 - l'utente è riconosciuto come proprietario attraverso l'identificazione per mezzo della password.
Con ogni comando possono essere inviati fino a 16 nick; il resto sarà ignorato. Se nessun nickname è specificato verrà indicato lo stato del tuo nick.
Sintassi:
/msg NickServ STATUS nick codice-di-stato
Esempio:
/msg NickServ STATUS paolo


UNGROUP

NickServ - Ungroup

Questo comando rimuove il tuo nick, o se specificato, il nick indicato, dal gruppo in cui si trova.
Il nick che è stato rimosso dal gruppo mantiene data di registrazione, password, email, greet,
lingua, url, e icq.
Tutto il resto viene rimosso.
Non puoi rimuovere il tuo nick dal tuo gruppo se nel tuo gruppo è presente un solo nick.

Sintassi:
/msg NickServ UNGROUP [nickname]

Esempio:
/msg NickServ UNGROUP pippo


UPDATE

NickServ - UPDATE

A ggiorna il tuo stato attuale, ovvero controlla eventuali nuovi memo, imposta i chanmode necessari e aggiorna il tuo vhost e i tuoi userflags (lastseentime, ecc).
Sintassi:
/msg NickServ UPDATE


ChanServ

I Comandi di ChanServ
ChanServ consente a chiunque abbia registrato e autorizzato il proprio nickname con NickServ di registrare il proprio canale, in modo da poterlo gestire completamente senza bisogno di un BOT, evitando che altri utenti non autorizzati prendano il controllo dei canali limitandone accesso agli utenti.

Il Founder viene automaticamente ownato da ChanServ quando entra nel canale, e ha accesso a tutti i comandi e può gestire le liste OWNER, PROTECT , SOP, AOP, HOP, VOP, AKICK. Può inoltre oppare (rendere operatori) utenti non presenti nella lista.
I canali scadono automaticamente se nessun operatore delle liste accede al canale entro 60 giorni con il nick identificato oppure se scade il nick del Owner, a meno che non sia stato settato un successor.
  • ACCESS - Gestisce la lista degli utenti con privilegi
  • AKICK - Gestisce la lista akick
  • AOP - Gestione lista AutoOp
  • BAN - Permette di bannare un utente
  • CLONE - Copia tutte le impostazioni da un canale ad un altro
  • DEHALFOP - Rimuove lo stato di HALFOP al nick specificato a te stesso in un canale
  • DEOP - Rimuove lo stato di OP al nick specificato o a te stesso in un canale
  • DEOWNER - Rimuove lo stato di OWNER al nick specificato o a te stesso in un canale
  • DEPROTECT - Rimuove lo stato di PROTECT al nick specificato o a te stesso in un canale
  • DEVOICE - Rimuove lo stato di VOICE al nick specificato o a te stesso in un canale
  • DOWN - Rimuove lo stato di un nick specificato in un canale
  • DROP - Annulla la registrazione di un canale
  • ENFORCE - Forza l'impostazione di vari modi canale e opzioni
  • ENTRYMSG - Gestisce il messaggio d'ingresso del canale
  • FLAGS - Modifica la lista degli utenti con privilegi
  • GETKEY - Recupera la password (+k) del canale specificato
  • GSTATS - Mostra le tue stats globali
  • GTOP - Mostra la top 3 utenti del network
  • GTOP10 - Mostra la top 10 utenti del network
  • HALFOP - Assegna lo stato di HALFOP sul nick specificato in un canale
  • HELP - Mostra questa lista e da informazioni sui comandi
  • HOP - Modifica la lista degli utenti HOP
  • INFO - Mostra le informazioni su un canale registrato
  • INVITE - Invita te stesso oppure il nick specificato in un canale
  • KICK - Espelle il nick specificato da un canale
  • LEVELS - Ridefinisce i privilegi dei livelli di accesso
  • LIST - Mostra la lista dei canali registrati
  • LOG - Configura e impostazioni di logging del canale
  • MODE - Controlla i modi e il blocco dei modi di un canale
  • OP - Assegna lo stato di operatore su te stesso o sul nick specificato in un canale
  • OWNER - Assegna lo stato di owner sul nick specificato in un canale
  • PROTECT - Assegna lo stato di PROTECT sul nick specificato in un canale
  • QOP - Modifica la lista degli utenti QOP
  • REGISTER - Registra un canale
  • SET - Permette di cambiare le impostazioni e le informazioni di un canale
  • SOP - Modifica la lista degli utenti SOP
  • STATS - Mostra le statistiche del tuo canale
  • STATUS - Trova lo stato di un utente in un canale
  • SYNC - Sincronizza i modi utente nel canale
  • TOP - Mostra la top 3 utenti di un canale
  • TOP10 - Mostra la top 10 utenti di un canale
  • TOPIC - Gestisce il topic del canale specificato
  • UNBAN - Rimuove tutti i ban che impediscono ad un utente di accedere a un canale
  • UP - Aggiorna lo stato del nick specifico in un canale
  • VOICE - Assegna lo stato di voice ad un utente in un canale
  • VOP - Modifica la lista degli utenti VOP

Per maggiori informazioni, una volta connessi alla rete IRC, digitare: /msg ChanServ HELP


ACCESS

ChanServ - ACCESS
Gestisce la lista di accesso del canale.
La lista di accesso specifica quali utenti hanno diritto
allo stato di operatore di canale e ai vari comandi di
ChanServ sul canale. Utenti in diversi livelli avranno a
disposizione diversi privilegi; per avere informazioni
specifiche, puoi digitare /msg ChanServ HELP ACCESS LEVELS.
I nick che non si trovano nella lista di accesso hanno
livello 0.
Il comando ACCESS ADD aggiunge il nick specificato alla
lista di accesso con il livello specificato; se il nick è
già presente nella lista, il suo livello viene modificato,
impostandolo a quello specificato nel comando. Il livello
del nick specificato deve essere minore di quello del nick
che invia il comando, e se il nick è già presente nella
lista, il livello attuale di quel nick deve essere minore di
quello del nick che invia il comando.

Il comando ACCESS DEL rimuove il nick specificato dalla
lista di accesso. Se viene specificata una lista, i record
corrispondenti vengono rimossi. (Guarda l'esempio di
LIST)
Il comando ACCESS LIST mostra la lista di accesso. Se viene
utilizzata una wildcard per la mask, solo i record che
corrispondono alla mask vengono mostrati. Se viene specificata
una lista, i record corrispondenti vengono mostrati.
Ad esempio:

ACCESS #canale LIST 2-5,7-9
 Mostra i record della lista che hanno numero da 2
a 5 e da 7 a 9 (il 6 è quindi escluso).

Il comando ACCESS CLEAR svuota completamente la lista di
accesso.
Sintassi:
/msg ChanServ ACCESS #canale ADD nick livello
/msg ChanServ ACCESS #canale DEL { nick | numero | lista }
/msg ChanServ ACCESS #canale LIST [ mask | lista ]
/msg ChanServ ACCESS #canale CLEAR


AKICK

ChanServ - AKICK
Gestice la lista AutoKick. Se un utente che si trova nella
lista AutoKick cerca di entrare nel canale, ChanServ lo
bannerà dal canale e poi lo espellerà (kick).

Il comando AKICK ADD aggiunge il nick specificato alla
lista AutoKick. Se viene specificato un motivo, quella frase
sarà utilizzato quando l'utente viene kickato; altrimenti,
verrà utilizzata la frase standard ""You have been banned from
the channel". In alternativa al nick può essere usata una
hostmask.
When akicking a registered nick the nickserv account
will be added to the akick list instead of the mask.
All users within that nickgroup will then be akicked.

Il comando AKICK STICK mantiene permanentemente il ban
sulla mask specificata. Se qualcuno cerca di rimuovere il ban,
ChanServ lo imposterà di nuovo. Questo comando non può essere
usato contro i nick registrati.

Il comando AKICK UNSTICK annulla l'effetto del comando
AKICK STICK, permettendo di rimuovere il ban dal canale.

Il comando AKICK DEL rimuove il nick o la mask specificata
dalla lista AutoKick. Non rimuove, però, i ban piazzati da
un AutoKick, che devono quindi essere rimossi manualmente.

Il comando AKICK LIST mostra la lista AutoKick, o, se
specificata, solo i record che corrispondono alla mask
indicata.
Il comando AKICK VIEW mostra la lista Autokick, fornendo
più informazioni del comando AKICK LIST.

Il comando AKICK ENFORCE fa sì che ChanServ forzi la
lista AutoKick attuale, rimuovendo dal canale tutti gli
utenti che corrispondono alle varie mask presenti nella
lista.

Il comando AKICK CLEAR svuota la lista AutoKick.
Sintassi:
/msg ChanServ AKICK #canale ADD { nick | mask } motivo
/msg ChanServ AKICK #canale STICK mask
/msg ChanServ AKICK #canale UNSTICK mask
/msg ChanServ AKICK #canale DEL { nick | mask | entry-num | list }
/msg ChanServ AKICK #canale LIST [ mask | entry-num | list ]
/msg ChanServ AKICK #canale VIEW [ mask | entry-num | list ]
/msg ChanServ AKICK #canale ENFORCE
/msg ChanServ AKICK #canale CLEAR


AOP

ChanServ - AOP
Gestisce la lista AOP (AutoOP) del canale.
La lista AOP dà agli utenti il diritto di essere auto-oppati,
di richiedere l'invito, di rimuovere i ban su se stessi, di
far mostrare il messaggio di saluto (greet) quando entrano,
e così via.

Il comando AOP ADD aggiunge il nick specificato alla
lista AOP.

Il comando AOP DEL rimuove il nick specificato dalla
lista AOP. Se viene specificata una lista, i record
corrispondenti vengono rimossi. (Guarda l'esempio di
LIST)

Il comando AOP LIST mostra la lista AOP. Se viene
utilizzata una wildcard per la mask, solo i record che
corrispondono alla mask vengono mostrati. Se viene
specificata una lista, i record corrispondenti vengono
mostrati.
Ad esempio:

AOP #canale LIST 2-5,7-9
 Mostra i record AOP che hanno numero da 2
a 5 e da 7 a 9 (il 6 è quindi escluso).

Il comando AOP CLEAR svuota la lista AOP.

I comandi AOP ADD e AOP DEL sono limitati ai SOP
e superiori, mentre il comando AOP CLEAR può essere
utilizzato soltanto dal fondatore del canale. Comunque,
tutti gli utenti nella lista AOP possono usare il comando
AOP LIST.

N.B.Questo comando potrebbe essere stato disabilitato per
il tuo canale; in questo caso dovrai usare la lista di
accesso. Digita /msg ChanServ HELP ACCESS per
maggiori informazioni, e /msg ChanServ HELP SET XOP
per scoprire come passare da un sistema all'altro.

Sintassi:
/msg ChanServ AOP #canale ADD nick
/msg ChanServ AOP #canale DEL { nick | numero | lista }
/msg ChanServ AOP #canale LIST [ mask | lista ]
/msg ChanServ AOP #canale CLEAR
Esempio:
/msg ChanServ AOP #ChanGratis ADD GrandePuffo


BAN

ChanServ - BAN
Banna (non permette l'accesso) il nick specificato sul
canale. Se non viene indicato alcun nick, banna l'utente
che ha inviato il comando. Se non viene indicato né il
nick né il canale, l'utente che ha inviato il comando verrà
bannato su tutti i canali in cui si trova e in cui ha
abbastanza privilegi.
Di default, il comando è limitato agli AOP o agli utenti con
livello di accesso 5 o superiori sul canale.
Sintassi:
/msg ChanServ BAN #canale nick motivo
Esempio:
/msg ChanServ BAN #Arcobaleno Pippo fuori da qui!


CLONE*

ChanServ - CLONE
Copia tutte le impostazioni, access, akicks, ecc. Dal canale al canale di destinazione.
Per quanto riguarda ACCESS, AKICK, BADWORDS,
o LIVELLI vengono clonate solo le rispettive impostazioni.
Devi essere il fondatore dei canali.
Sintassi:
/msg ChanServ CLONE canale canale di destinazione impostazione
Esempio:
/msg ChanServ CLONE #canale #canale2 ACCESS


DEHALFOP

ChanServ - DEHALFOP
Rimuove lo stato di mezzo operatore (halfop, -h) a un utente
sul canale specificato. Se non viene indicato alcun nick,
dà l'halfop all'utente che invia il comando. Se non viene
indicato né canale né nick, dà l'halfop all'utente che invia
il comando su tutti i canali in cui si trova e in cui ha abbastanza privilegi.

Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori, oppure ai HOP o agli
utenti con livello 4 o superiori per l'halfop su se stessi.
Sintassi:
/msg ChanServ DEHALFOP #canale nick
Esempio:
/msg ChanServ DEHALFOP #GlobalIRC Pippo


DEOP

ChanServ - DEOP
Rimuove lo stato di operatore (op, -o) a un utente sul
canale specificato. Se non viene indicato alcun nick,
"deoppa" l'utente che invia il comando. Se non viene
indicato né canale né nick, deopperà l'utente che invia
il comando su tutti i canali in cui si trova e in cui
ha abbastanza privilegi.
Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori.
Sintassi:
/msg ChanServ DEOP #canale nick
Esempio:
/msg ChanServ DEOP #GlobalIRC Pippo


DEOWNER

ChanServ - DEOWNER
Ti toglie lo stato di proprietario (owner, -q) sul canale
che specifichi. Se non indichi nessun canale, lo stato di
proprietario ti sarà rimosso su tutti i canali su cui ti
trovi e in cui hai abbastanza privilegi.
Il comando è limitato agli utenti che hanno accesso di fondatore
Sintassi:
/msg ChanServ DEOWNER #canale


DEPROTECT

ChanServ - DEPROTECT
Rimuove lo stato di protezione (-a) da un utente sul canale
specificato. Se non viene indicato alcun nick, toglie la
protezione all'utente che invia il comando. Se non viene
indicato né canale né nick, toglie la protezione all'utente
che invia il comando su tutti i canali in cui si trova e in
cui ha abbastanza privilegi.
Di default, il comando è limitato al fondatore del canale,
oppure ai SOP o agli utenti con livello 10 o superiori per
la rimozione della protezione su se stessi.
Sintassi:
/msg ChanServ DEPROTECT #canale nick
Esempio:
/msg ChanServ DEPROTECT #GlobalIRC Pippo


DEVOICE

ChanServ - DEVOICE
Rimuove lo stato di voice (-v) a un utente sul canale
specificato. Se non viene indicato alcun nick, dà il
voice all'utente che invia il comando. Se non viene
indicato né canale né nick, dà il voice all'utente che
invia il comando su tutti i canali in cui si trova e in
cui ha abbastanza privilegi.

Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori, oppure ai VOP o agli
utenti con livello 3 o superiori per il voice su se stessi.
Sintassi:
/msg ChanServ DEVOICE #canale nick
Esempio:
/msg ChanServ DEVOICE #GlobalIRC Pippo


DOWN*

ChanServ - DOWN
Rimuove le modalità di stato dei nick selezionati su un canale.
Se il nick è omesso quindi il tuo stato viene rimosso.
Se il canale è omesso allora lo stato del tuo canale viene rimosso su tutti i canali in cui ti trovi.
Sintassi:
/msg ChanServ DOWN canale nickname
Esempio:
/msg ChanServ DOWN #canale pippo


DROP

ChanServ - DROP
Deregistra il canale specificato. Può essere usato soltanto
da un fondatore di un canale.
Sintassi:
/msg ChanServ DROP #canale #canale
Esempio:
/msg ChanServ DROP #ACielSereno #ACielSereno


ENFORCE

ChanServ - ENFORCE
Forza diversi modi di canale ed opzioni . Il parametro canale
indica su quale canale forzare i modi e le opzioni. Il parametro
cosa indica i modi e le opzioni da forzare, e possono essere
qualsiasi delle opzioni SECUREOPS, RESTRICTED, REGONLY, SSLONLY,
BANS, o LIMIT.

Usa SECUREOPS per forzare l' opzione SECUREOPS, anche se questa non
è abilitata.
Usa RESTRICTED per forzare l' opzione RESTRICTED, anche
se questa non è abilitata.
Usa REGONLY per kickare tutti gli utenti non
registrati dal canale.
Usa SSLONLY per kickare tutti gli utenti che non usano
una connessione SSL dal canale.
BANS forzerà i bans impostati nel canale
kickando gli utenti corrispondenti ad essi, LIMIT kickerà gli utenti fino
a quando il numero degli stessi non scende al di sotto del limite canale,
se un limite Ã¨ impostato
Sintassi:
/msg ChanServ ENFORCE #canale [cosa]


ENTRYMSG*

ChanServ - ENTRYMSG
Controlla il messaggio che sarà inviato agli utenti quando accedono al canale.
Di seguito i comandi elencati:
Il comando ENTRYMSG ADD aggiunge il messaggio specificato all'elenco dei messaggi mostrati agli utenti quando entrano nel canale.
Il comando ENTRYMSG DEL rimuove il messaggio specificato dall'elenco dei messaggi mostrati agli utenti quando entrano nel canale.
Puoi rimuovere un messaggio specificandone il numero che puoi ottenere elencando i messaggi come spiegato di seguito.
Il comando ENTRYMSG LIST visualizza un elenco di messaggi mostrato agli utenti quando entrano nel canale.
Il comando ENTRYMSG CLEAR cancella tutte le voci dall'elenco dei messaggi mostrati agli utenti quando entrano nel canale, disabilitando efficacemente i messaggi di entrata.
L'aggiunta, l'eliminazione o la cancellazione dei messaggi di entrata richiede l'autorizzazione con il comando SET
Sintassi:
/msg ChanServ ENTRYMSG canale ADD messaggio
/msg ChanServ ENTRYMSG canale DEL numero
/msg ChanServ ENTRYMSG canale LIST
/msg ChanServ ENTRYMSG canale CLEAR


FLAGS*

ChanServ - FLAGS
FLAGS è un altro metodo di gestione della lista di accesso del canale, simile ai metodi XOP e ACCESS.
Di seguito i comandi elencati:
Il comando MODIFY consente di modificare l'elenco di accesso.
Se la maschera è non già nella lista di accesso viene aggiunto, quindi le modifiche vengono applicate.
Se la maschera non ha più contrassegni, la maschera viene rimossa dall'elenco di accesso. Inoltre, puoi usare + * o - * per aggiungere o rimuovere tutti i flag, rispettivamente.
Sei solo in grado di modificare l'elenco di accesso se si dispone dell'autorizzazione appropriata sul canale, e anche in questo caso puoi solo dare ad altre persone l'accesso all'equivalente di ciò che è il tuo accesso.
Il comando LIST ti permette di mostrare la lista completa di tutti i records presenti nella lista di accesso del canale.
Se specifacata una mask, la mask viene confrontata con tutti i records esistenti nella lista di accesso, e solamente i records corrispondenti vengono mostrati.
Se specificato un set di flags, vengono mostrati solo quelli presenti nella lista di accesso con il flag specificato.
Il comando CLEAR cancella l'elenco di accesso al canale. Ciò richiede l'accesso al fondatore del canale.
Sintassi:
/msg ChanServ FLAGS canale MODIFY mask nuovamask
/msg ChanServ FLAGS canale LIST mask | +flags
/msg ChanServ FLAGS canale CLEAR
Le flags disponibili sono:
A - Stato di protect automatico al momento del join
a - Autorizzato a dare o rimuovere lo stato di protect agli utenti
a - Autorizzato a dare o rimuovere lo stato di protect a se stesso
b - Autorizzato a impostare ban sugli utenti
B - Autorizzato ad usare i comandi SAY e ACT
c - Autorizzato ad usare i comandi fantasy
f - Autorizzato alla modifica della lista di accesso
f - Autorizzato alla visualizzazione della lista di accesso
F - Autorizzato ad usare comandi normalmente limitati ai founders dei canali
G - Autorizzato ad usare il comando GETKEY
g - Messaggio di saluto mostrato all' accesso
H - Stato di halfop automatico al momento del join
h - Autorizzato a dare o rimuovere lo stato di halfop agli utenti
h - Autorizzato a dare o rimuovere lo stato di halfop a se stesso
I - Autorizzato a ottenere l' output completo del comando INFO
i - Autorizzato ad usare il comando INVITE
K - Autorizzato ad usare il comando AKICK
K - Autorizzato alla modifica della lista badwords del canale
k - Autorizzato ad usare il comando KICK
K - No kick firmati quanto Ã¨ usato SIGNKICK LEVEL
m - Autorizzato alla lettura dei memo del canale
N - Impedisce agli utenti di essere kickati dai Services
O - Stato di op automatico al momento del join
o - Autorizzato a dare o rimuovere lo stato di op agli utenti
o - Autorizzato a dare o rimuovere lo stato di op a se stesso
Q - Stato di owner automatico al momento del join
q - Autorizzato a dare o rimuovere lo stato di owner agli utenti
q - Autorizzato a dare o rimuovere lo stato di owner a se stesso
s - Autorizzato ad assegnare/rimuovere un bot
s - Autorizzato ad usare il comando MODE
s - Autorizzato ad impostare i settings del canale
t - Autorizzato al cambio del topic del canale
u - Autorizzato a rimuovere i ban sugli utenti
V - Stato di voice automatico al momento del join
v - Autorizzato a dare o rimuovere lo stato di voice agli utenti
v - Autorizzato a dare o rimuovere lo stato di voice a se stesso


GETKEY

ChanServ - GETKEY
Restituisce la chiave (password) del canale specificato.
Questo comando è pensato per essere usato dai bot e dagli
script, e il suo output ha questo formato:

KEY <canale> <chiave>
chiave corrisponde a "NO KEY" se il canale non richiede una chiave.
Sintassi:
/msg ChanServ GETKEY #canale


GSTATS*

ChanServ - GSTATS
Mostra le tue Statistiche globali, all'interno della network
Sintassi:
/msg ChanServ GSTATS


GTOP

ChanServ - GTOP
Mostra i top 3 utenti, all'interno della network
Sintassi:
/msg ChanServ GTOP


GTOP10

ChanServ - GTOP10
Mostra la top 10 utenti, all'interno della network
S intassi:
/msg ChanServ GTOP10


HALFOP

ChanServ - HALFOP
Assegna lo stato di mezzo operatore (halfop, +h) a un utente
sul canale specificato. Se non viene indicato alcun nick,
dà l'halfop all'utente che invia il comando. Se non viene
indicato né canale né nick, dà l'halfop all'utente che invia
il comando su tutti i canali in cui si trova e in cui ha abbastanza privilegi.

Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori, oppure ai HOP o agli
utenti con livello 4 o superiori per l'halfop su se stessi.
Sintassi:
/msg ChanServ HALFOP #canale nick
Esempio:
/msg ChanServ HALFOP #GlobalIRC Pippo


HELP

ChanServ - HELP
È il comando per ottenere help on-line sul servizio ChanServ.

Sintassi:
/msg ChanServ HELP [comando]
Esempi:
/msg ChanServ HELP register


HOP

ChanServ - HOP
Gestisce la lista HOP (HalfOP) del canale.
La lista HOP dà agli utenti il diritto di essere
"half-oppati" sul tuo canale.

Il comando HOP ADD aggiunge il nick specificato alla
lista HOP.

Il comando HOP DEL rimuove il nick specificato dalla
lista HOP. Se viene specificata una lista, i record
corrispondenti vengono rimossi. (Guarda l'esempio di
LIST)

Il comando HOP LIST mostra la lista HOP. Se viene
utilizzata una wildcard per la mask, solo i record che
corrispondono alla mask vengono mostrati. Se viene
specificata una lista, i record corrispondenti vengono
mostrati.
Ad esempio:

HOP #canale LIST 2-5,7-9
 Mostra i record HOP che hanno numero da 2
a 5 e da 7 a 9 (il 6 è quindi escluso).

Il comando HOP CLEAR svuota la lista HOP.

I comandi HOP ADD, HOP DEL e HOP LIST sono limitati
agli AOP e superiori, mentre il comando HOP CLEAR può
essere utilizzato soltanto dal fondatore del canale.

N.B. Q uesto comando potrebbe essere stato disabilitato per
il tuo canale; in questo caso dovrai usare la lista di
accesso. Digita /msg ChanServ HELP ACCESS per
maggiori informazioni, e /msg ChanServ HELP SET XOP
per scoprire come passare da un sistema all'altro.
Sintassi:
/msg ChanServ HOP #canale ADD nick
/msg ChanServ HOP #canale DEL { nick | numero | lista }
/msg ChanServ HOP #canale LIST [ mask | lista ]
/msg ChanServ HOP #canale CLEAR
Esempio:
/msg ChanServ HOP #ChanGratis ADD GrandePuffo


INFO

ChanServ - INFO
Mostra varie informazioni a proposito del canale
specificato (a patto che sia registrato), tra cui il
fondatore, il giorno di registrazione, l'ultimo utilizzo,
la descrizione e il blocco dei modi, se presente. Se
viene specificata l'opzione ALL , verranno mostrati
anche il successore e il messaggio di ingresso.

Di default, l'opzione ALL è limitata a coloro che hanno l'accesso come fondatore sul canale.
Sintassi:
/msg ChanServ INFO #canale ALL


INVITE

ChanServ - INVITE
Chiede a ChanServ di invitarti nel canale specificato.

Di default, il comando è limitato agli AOP o agli utenti con
livello di accesso 5 o superiori sul canale.
Sintassi:
/msg ChanServ INVITE #canale


KICK

ChanServ - KICK
Espelle (kick) il nick specificato dal canale. Se non viene
indicato alcun nick, kicka l'utente che ha inviato il comando.
Se non viene indicato né il nick né il canale, l'utente che
ha inviato il comando verrà kickato da tutti i canali in cui
si trova e in cui ha abbastanza privilegi.

Di default, il comando è limitato agli AOP o agli utenti con
livello di accesso 5 o superiori sul canale.
Sintassi:
/msg ChanServ KICK #canale nick motivo
Esempio:
/msg ChanServ KICK #GlobalIRC Pippo Non Disturbare


LEVELS

ChanServ - LEVELS
Il comando LEVELS permette un controllo preciso dei
significati dei livelli di accesso numerici usati nei
canali. Con questo comando, è possibile definire il
livello di accesso richiesto per la maggior parte delle
funzioni di ChanServ.
(I comandi SET FOUNDER e SET PASSWORD , nonché questo
comando, sono sempre riservati al fondatore del canale).
LEVELS SET permette di definire il livello di accesso
necessario per una funzione o per un gruppo di funzioni.

LEVELS DISABLE (o, abbreviato, DIS ) disattiva una
funzione automatica o non permette più l'accesso a una
funzione se non al fondatore del canale.

LEVELS LIST mostra i livelli di accesso attuali per
ogni funzione e per i gruppi di funzioni.

LEVELS RESET reimposta i livelli ai valori di default
di un canale appena creato (per maggiori informazioni,
digita HELP ACCESS LEVELS ).
Per una lista delle funzioni di cui puoi cambiare i
livelli, digita HELP LEVELS DESC .
Sintassi:
/msg ChanServ LEVELS #canale SET tipo livello
/msg ChanServ LEVELS #canale { DIS | DISABLE }
/msg ChanServ LEVELS #canale LIST
/msg ChanServ LEVELS #canale RESET


LIST*

ChanServ - LIST
Mostra la lista dei canali registrati corrispondenti la chiave specificata. I canali con l'opzione PRIVATE impostata saranno mostrati solo ai Services Operators.
I canali con l' opzione NOEXPIRE impostata avranno come prefisso un ! (solo per i Services Operators).
Nota: che l' uso del carattere '#' specifica un range, i nomi dei canali devono essere scritti senza cancelletto.
Se le opzioni SUSPENDED o NOEXPIRE sono specificate, solamente i canali che sono rispettivamente SUSPENDED o hanno la flag NOEXPIRE
saranno mostrati.
Se specificate opzioni multiple, tutti i canali corrispondenti almeno un opzione saranno mostrati.
Nota: che queste opzioni sono limitate ai Services Operators.
Sintassi:
/msg ChanServ LIST pattern SUSPENDED NOEXPIRE
Esempi:

/msg ChanServ LIST *anope*
Mostra tutti i canali registrati che contengono anope nei
loro nomi (case insensitive).

/msg ChanServ LIST * NOEXPIRE
Mostra tutti i canali registrati che sono stati impostati NOEXPIRE.

/msg ChanServ LIST #51-100
 Mostra tutti i canali registrati compresi nel range specificato (51-100).

E' supportato l' uso di espressioni regolari utilizzando il motore regex/pcre. Se vuoi puoi includere la mask tra //.


LOG

ChanServ - LOG
Il comando LOG consente agli utenti di configurare le impostazioni di registrazione per il loro canale.
Se nessun parametro è dato questo comando elenca i metodi di registrazione correnti per questo canale.
Altrimenti, il comando deve essere un nome di comando e un metodo è uno dei seguenti metodi di registrazione:

MESSAGE [stato], NOTICE [stato], MEMO

Che sono usati per messaggio, avviso e memo del canale rispettivamente.
Con MESSAGE o NOTICE è necessario disporre di un bot di servizio assegnato e aggiunto al tuo canale. Lo stato può essere uno stato di canale come @ o +.

Per rimuovere un metodo di registrazione, utilizzare la stessa sintassi che si desidera aggiungere.
S intassi:
/msg ChanServ LOG canale
/msg ChanServ LOG canale metodo stato
Esempio:
/msg ChanServ LOG #anope chanserv / access MESSAGE @

Trasmetterebbe messaggi agli operatori di canale ogni volta che qualcuno usava il Comando ACCESS su ChanServ sul canale.


MODE

ChanServ - MODE
Controlla principalmente il blocco dei modi e l' accesso ai modi (che è una cosa diversa dall' accesso al canale) in un canale.

Il comando MODE LOCK permette di aggiungere, rimuovere, e vedere il blocco dei modi in un canale.
Se un mode è bloccato o disattivati, i services non permetteranno a quel mode di essere cambiato. Il comando SET rimuovera tutti i modi bloccati e imposterà i nuovi modi specificati, mentre ADD e DEL apportano modifiche ai modi bloccati esistenti.
Sintassi:
/msg ChanServ MODE canale LOCK {ADD|DEL|SET|LIST} what
/msg ChanServ MODE canale SET modes
/msg ChanServ MODE canale CLEAR what
Esempi:
/msg ChanServ MODE #channel LOCK ADD +bmnt *!*@*aol *
Il comando MODE SET permette di impostare i modi utilizzando i services. Le wildcards * e ? possono
essere specificate come parametri per le liste e gli status modes.
Esempi:
/msg ChanServ MODE #channel SET +v *
 Imposta lo stato di voice a tutti gli utenti presenti nel canale.

/msg ChanServ MODE #channel SET -b c:*
 Rimuove tutti i ban estesi che iniziano con c:

Il comando MODE CLEAR è un modo semplice per rimuovere tutti i modi in un canale. "what" può essere uno tra bans, exempts, inviteoverrides, ops, halfops, or voices. Se il parametro "what" è omesso, allora tutti i modi saranno rimossi dal canale.


OP

ChanServ - OP
Assegna lo stato di operatore (op, +o) a un utente sul
canale specificato. Se non viene indicato alcun nick,
"oppa" l'utente che invia il comando. Se non viene
indicato né canale né nick, opperà l'utente che invia
il comando su tutti i canali in cui si trova e in cui
ha abbastanza privilegi.
Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori.
Sintassi:
/msg ChanServ OP #canale nick
Esempio:
/msg ChanServ OP #GlobalIRC Pippo


OWNER

ChanServ - OWNER
Ti assegna lo stato di proprietario (owner, +q) sul canale
che specifichi. Se non indichi nessun canale, lo stato di
proprietario ti sarà assegnato su tutti i canali su cui ti
trovi e in cui hai abbastanza privilegi.
Il comando è limitato agli utenti che hanno accesso di fondatore.
Sintassi:
/msg ChanServ OWNER #canale


PROTECT

ChanServ - PROTECT
Assegna lo stato di protezione (+a) a un utente sul canale
specificato. Se non viene indicato alcun nick, dà la
protezione all'utente che invia il comando. Se non viene
indicato né canale né nick, dà la protezione all'utente che
invia il comando su tutti i canali in cui si trova e in
cui ha abbastanza privilegi.
Di default, il comando è limitato al fondatore del canale,
oppure ai SOP o agli utenti con livello 10 o superiori per la protezione su se stessi.
Sintassi:
/msg ChanServ PROTECT #canale nick
Esempio:
/msg ChanServ PROTECT #GlobalIRC Pippo


QOP

ChanServ - QOP
Gestisce la lista QOP di un canale. Gli utenti che vengono aggiunti nella lista QOP ricevono i seguenti privilegi:

ASSIGN, AUTOOWNER, FOUNDER, INFO, MODE, OWNER, OWNERME, PROTECT, SET, SIGNKICK

Il comando QOP ADD aggiunge il nickname specificato alla lista QOP.

Il comando QOP DEL rimuove il nick specificato dalla lista QOP. Se viene specificata una lista, i record corrispondenti vengono rimossi. (Guarda l'esempio di LIST.)

Il comando QOP LIST mostra la lista QOP. Se viene utilizzata una wildcard per la mask, solo i record che corrispondono alla mask vengono mostrati. Se viene specificata una lista, i record corrispondenti vengono mostrati.

Il comando QOP CLEAR svuota la lista QOP Sono disponibili metodi alternativi per la modifica delle liste di accesso dei canali.
Digita /msg ChanServ HELP FLAGS per ottenere maggiori informazioni sulla lista di accesso.
Sintassi:
/msg ChanServ QOP canale ADD mask
/msg ChanServ QOP canale DEL { mask | entry-num | list }
/msg ChanServ QOP canale LIST mask | list
/msg ChanServ QOP canale CLEAR
Esempio:
/msg ChanServ QOP #channel LIST 2-5,7-9
 Mostra i record QOP che hanno numero da 2 a 5 e da 7 a 9 (il 6 è quindi escluso).


REGISTER

ChanServ - REGISTER
Registra un canale nel database di ChanServ. Per poter usare questo commando, prima di tutto, devi essere operatore (op)
del canale che intendi registrare. La descrizione, che deve essere specificata, è una descrizione generica dello scopo del canale.

Quando registri un canale, vieni registrato come "founder" del canale. Il founder di un canale puo modificare tutte le impostazioni del canale e riceverà automaticamente da ChanServ i privilegi di operatore del canale quando vi accede.

Consulta il comando ACCESS (/msg ChanServ HELP ACCESS) per informazioni su come assegnare alcuni di questi privilegi ad altri utenti del canale.

NOTA: Per registrare un canale, è necessario aver prima registrato il tuo nickname.
Sintassi:
/msg ChanServ REGISTER #canale descrizione
Esempio:
/msg ChanServ REGISTER #ChatGratis Chat gratuita e senza registrazione


SET

ChanServ - SET
Permette al fondatore di un canale di impostare varie opzioni e informazioni del canale stesso.
Opzioni disponibili:
  • AUTOOP Abilita/disabilita l'impostazione automatica dello stato agli utenti
    Attiva o disattiva l'opzione ChanServ autoop per il canale. Quando l'opzione è disabilitata, gli utenti che accedono
    al canale non otteranno automaticamente alcuno stato da ChanServ.
    Sintassi:     /msg ChanServ SET AUTOOP channel {ON | OFF}
  • BANTYPE Imposta il tipo di ban che sarà usato dai Services
    Imposta il tipo di can che sarÃ usato dai Services in tutte le occasioni in cui dovranno bannare un utente dal canale.

    Bantype è un numero tra 0 e 3 che indica:
    0: ban nella forma     *!user@host
    1: ban nella forma *!*user@host
    2: ban nella forma *!*@host
    3: ban nella forma *!*user@*.dominio
    Sintassi: /msg ChanServ SET BANTYPE channel bantype
  • CHANSTATS Attiva o disattiva le statistiche chanstats
    Imposta le statistiche ChanStats del canale ON e OFF
    Sintassi:     /msg ChanServ SET CHANSTATS { ON | OFF }
  • DESC Imposta la descrizione del canale
    Imposta la descrizione del canale, che viene mostrata con i comandi LIST e INFO .
    Sintassi:     /msg ChanServ SET DESC descrizione
  • DESCRIPTION Imposta la descrizione del canale
    Imposta la descrizione del canale, che viene mostrata usando i comandi LIST e INFO.
    Sintassi: /msg ChanServ SET DESCRIPTION canale [descrizione]
  • EMAIL Associa un indirizzo e-mail al canale
    Associa l'indirizzo e-mail specificato al canale. Questo indirizzo sarà mostrato quando qualcuno richiede informazioni relative al canale con il comando INFO. Se non viene specificato nessun indirizzo, l'indirizzo attuale del canale viene eliminato.
    Sintassi: /msg ChanServ SET EMAIL [indirizzo e-mail]
    Esempio: /msg ChanServ SET EMAIL trottolinoamoroso@globalirc.it
  • FOUNDER Imposta il fondatore del canale
    Imposta il nuovo fondatore del canale. Il nick specificato deve essere registrato.
    Sintassi:     /msg ChanServ SET FOUNDER nick
  • KEEPMODES Mantiene i modi quando il canale non è in uso
    Attiva o disattiva il mantenimento dei modi per il canale specificato. Quando il mantenimento dei modi è attivo,
    i services memorizzeranno i modi impostati nel canale e provvederanno a reimpostatarli la prossima volta che il canale
    sarà creato.
    Sintassi: /msg ChanServ SET KEEPMODES channel {ON | OFF}
  • KEEPTOPIC Mantiene il topic quando il canale non è in uso
    Attiva o disattiva il mantenimento del topic per il canale.
    Quando il mantenimento del topic è attivo, il topic sarà memorizzato da ChanServ anche quando
    l'ultimo utente esce dal canale, e sarà reimpostato la volta successiva che entra qualcuno.
    Sintassi:     /msg ChanServ SET #canale KEEPTOPIC { ON | OFF }
  • PEACE Regola l'uso dei comandi critici
    Attiva o disattiva l'opzione "pace" per il canale.
    Quando l'opzione è attiva, gli utenti non potranno kickare, bannare o rimuovere uno stato di canale
    (op, mezzo op, ecc.) di un utente con livello superiore, attraverso i comandi di ChanServ.
    Sintassi:     /msg ChanServ SET #canale PEACE { ON | OFF }
  • PERSIST Imposta il canale come permanente
         Abilita o disabilita l'impostazione persistente del canale. Quando è impostata la persistenza, il bot di servizio rimarrànel canale quando ha svuotato gli utenti.
    Se il tuo IRCd non ha un canale permanente (persistente) modalità è necessario disporre di un bot di servizio nel tuo canale per set persist, e non può essere non assegnato mentre persistono è acceso
    Se questa rete non ha BotServ abilitato e lo fa non ha una modalità canale permanente, lo farà ChanServ entra nel tuo canale quando imposti la persistenza (e parti quando è stato attivato).
    Se il tuo IRCd ha una modalità canale permanente (persistente) ed è impostato o disinserito (per qualsiasi motivo, incluso BLOCCO MODALITÀ),persist viene automaticamente impostato e disattivato per il canale. Inoltre, i servizi imposteranno o annulleranno questa modalità quando tu     imposta persistono on o off.
    Sintassi: /msg ChanServ SET PERSIST channel {ON | OFF}
  • PRIVATE Nasconde il canale dall'output del comando LIST
    Attiva o disattiva l'opzione di privacy per il canale.
    Quando questa opzione è attiva, il canale non sarà incluso nella lista restituita da /msg ChanServ LIST.
    Sintassi:     /msg ChanServ SET #canale PRIVATE { ON | OFF }
  • RESTRICTED Limita l'accesso al canale
    Attiva o disattiva l'opzione di accesso riservato per un canale.
    Quando questa opzione è attiva, gli utenti non in     l'elenco
    saranno invece kikkati e bannati dal canale    .
    Sintassi:     /msg ChanServ SET #canale RESTRICTED { ON | OFF }
  • SECURE Attiva le funzionalità di sicurezza di ChanServ
    Attiva o disattiva le funzionalità di sicurezza di ChanServ per il canale.
    Quando SECURE è attivo, solo gli utenti che hanno registrato il proprio nick
    con NickServ e che si sono identificati con la loro password
    avranno l'accesso sul canale secondo le liste di accesso.
    Sintassi:     /msg ChanServ SET #canale SECURE { ON | OFF }
  • SECUREFOUNDER Abilita un controllo più severo dello stato di fondatore
    Attiva o disattiva l'opzione secure founder per il canale.
    Quando l'opzione è attiva, solo il vero fondatore potrà deregistrare il canale (drop),
    cambiarne la password, il fondatore e il successore, mentre gli utenti identificati
    su ChanServ per il canale non potranno.
    Sintassi:     /msg ChanServ SET #canale SECUREFOUNDER { ON | OFF }
  • SECUREOPS Abilita un controllo più severo dello stato di operatore
    Attiva o disattiva l'opzione secure ops per il canale.
    Quando l'opzione è attiva, gli utenti che non sono nella
    lista di accesso non potranno avere lo stato di operatore di canale.
    Sintassi:     /msg ChanServ SET #canale SECUREOPS { ON | OFF }
  • SIGNKICK "Firma" i kick effettuati con il comando KICK
    Attiva o disattiva i nick "firmati" per il canale. Quando l'opzione è attiva,
    i kick effettuati con il comando KICK di ChanServ indicheranno anche il nick
    della persona che ha utilizzato il comando.

    Se usi LEVEL , il nick non sarà comunque mostrato se il kick è effettuato da qualcuno
    il cui livello di accesso è uguale o maggiore al livello SIGNKICK del canale.
    Per maggiori informazioni, guarda la guida LEVELS .
    Sintassi:     /msg ChanServ SET #canale SIGNKICK { ON | LEVEL | OFF }
  • SUCCESSOR Imposta il successore del fondatore del canale
    Imposta il successore del fondatore del canale. Se il nick del fondatore scade, o viene deregistrato mentre il canale è ancora registrato, il successore diventerà il nuovo fondatore del canale. In ogni caso, se il successore ha già troppi canali registrati (il massimo è 20), il canale verrà invece deregistrato, come se non ci fosse stato nessun successore. Il nick specificato deve essere registrato.
    Sintassi:     /msg ChanServ SET SUCCESSOR nick
  • URL Associa un URL al canale
    Associa l'URL specificato al canale. Questo URL sarà mostrato quando qualcuno richiede informazioni relative al canale con il comando INFO. Se non viene specificato nessun URL, l'URL attuale del canale viene eliminato.
    Sintassi: /msg ChanServ SET #canale URL [url]
    Esempio:     /msg ChanServ SET #StarTreck URL www.startreck.com


SOP

ChanServ - SOP
Gestisce la lista SOP (SuperOP) del canale.
La lista SOP dà agli utenti il diritto di essere auto-oppati
e protetti (+a), di modificare la lista AutoKick e quella
delle parolacce (badwords), di leggere le memo di canale, e così via.

Il comando SOP ADD aggiunge il nick specificato alla lista SOP.

Il comando SOP DEL rimuove il nick specificato dalla
lista SOP. Se viene specificata una lista, i record
corrispondenti vengono rimossi. (Guarda l'esempio di LIST)

Il comando SOP LIST mostra la lista SOP. Se viene
utilizzata una wildcard per la mask, solo i record che
corrispondono alla mask vengono mostrati. Se viene
specificata una lista, i record corrispondenti vengono mostrati.
Ad esempio:

SOP #canale LIST 2-5,7-9
 Mostra i record SOP che hanno numero da 2
a 5 e da 7 a 9 (il 6 è quindi escluso).

Il comando SOP CLEAR svuota la lista SOP.

I comandi SOP ADD, SOP DEL e SOP CLEAR sono limitati
al fondatore del canale. Comunque, tutti gli utenti nella
lista SOP possono usare il comando SOP LIST.

N.B. Questo comando potrebbe essere stato disabilitato per
il tuo canale; in questo caso dovrai usare la lista di
accesso. Digita /msg ChanServ HELP ACCESS per
maggiori informazioni, e /msg ChanServ HELP SET XOP
per scoprire come passare da un sistema all'altro.
Sintassi:
/msg ChanServ SOP #canale ADD nick
/msg ChanServ SOP #canale DEL { nick | numero | lista }
/msg ChanServ SOP #canale LIST [ mask | lista ]
/msg ChanServ SOP #canale CLEAR
Esempio:
/msg ChanServ SOP #ChanGratis ADD GrandePuffo


STATS

ChanServ - STATS
È il comando con il quale è possibile visualizzare, le statistiche del tuo canale.

Sintassi:
/msg ChanServ STATS


STATUS

ChanServ - STATUS
Questo comando mostra il livello di accesso degli utenti in un canale e a quali voci in lista di accesso, se presenti, corrispondono. Inoltre, informerà della presenza di eventuali voci auto kick che affliggono l' utente specificato.
L'uso di questo comando è limitato agli utenti che hanno accesso alla possibilità di modificare la lista di accesso del canale.
Sintassi:
/msg ChanServ STATUS canale nickname
Esempio:
/msg ChanServ STATUS #canale pippo


SYNC

ChanServ - SYNC
Sincronizza tutti i modi impostati sugli utenti di un canale con i modi che dovrebbero avere in base al loro accesso.
Sintassi:
/msg ChanServ SYNC canale
Esempio:
/msg ChanServ SYNC #canale


TOP

ChanServ - TOP
Mostra i top 3 utenti, di un
S intassi:
/msg ChanServ TOP


TOP10

ChanServ - TOP10
Mostra la top 10 utenti, di un canale
S intassi:
/msg ChanServ TOP10


TOPIC

ChanServ - TOPIC
Fa cambiare il topic a ChanServ. Se il nuovo topic
non viene specificato, il topic attuale sarà rimosso.
Questo comando è utile soprattutto quando l'opzione
SET TOPICLOCK è attiva. Per maggiori informazioni,
digita /msg ChanServ HELP SET TOPICLOCK .

Di default, il comando è limitato agli utenti con accesso di fondatore sul canale.
Sintassi:
/msg ChanServ TOPIC #canale topic
Esempio:
/msg ChanServ TOPIC #GlobalIRC Benvenuti nel canale ufficiale della net


UNBAN

ChanServ - UNBAN
Chiede a ChanServ di rimuovere tutti i ban che non ti
permettono di entrare sul canale specificato.
Di default, il comando è limitato agli AOP o agli utenti con
livello di accesso 5 o superiori sul canale.
Sintassi:
/msg ChanServ UNBAN #canale


UP

ChanServ - UP
Aggiorna le modalità di stato dei nick selezionati su un canale.
Se nick viene omesso, il tuo stato verrà aggiornato.
Se il canale viene omesso, lo stato del canale viene aggiornato su ogni canale in cui ti trovi.
Sintassi:
/msg ChanServ UP canale nickname
Esempio:
/msg ChanServ UP #canale pippo
/msg ChanServ UP #canale
/msg ChanServ UP


VOICE

ChanServ - VOICE
Assegna lo stato di voice (+v) a un utente sul canale
specificato. Se non viene indicato alcun nick, dà il
voice all'utente che invia il comando. Se non viene
indicato né canale né nick, dà il voice all'utente che
invia il comando su tutti i canali in cui si trova e in
cui ha abbastanza privilegi.

Di default, il comando è limitato agli AOP o agli utenti
con livello di accesso 5 o superiori, oppure ai VOP o agli
utenti con livello 3 o superiori per il voice su se stessi.
Sintassi:
/msg ChanServ VOICE #canale nick
Esempio:
/msg ChanServ VOICE #GlobalIRC Pippo


VOP

ChanServ - VOP
Gestisce la lista VOP (VOicePeople) del canale.
La lista VOP dà agli utenti il diritto di essere
voice sul tuo canale, e di ottenere il +v se non lo sono.

Il comando VOP ADD aggiunge il nick specificato alla
lista VOP.

Il comando VOP DEL rimuove il nick specificato dalla
lista VOP. Se viene specificata una lista, i record
corrispondenti vengono rimossi. (Guarda l'esempio di
LIST)

Il comando VOP LIST mostra la lista VOP. Se viene
utilizzata una wildcard per la mask, solo i record che
corrispondono alla mask vengono mostrati. Se viene
specificata una lista, i record corrispondenti vengono
mostrati.
Ad esempio:

VOP #canale LIST 2-5,7-9
 Mostra i record VOP che hanno numero da 2
a 5 e da 7 a 9 (il 6 è quindi escluso).

Il comando VOP CLEAR svuota la lista HOP.

I comandi VOP ADD, VOP DEL e VOP LIST sono limitati
agli HOP e superiori, mentre il comando VOP CLEAR può
essere utilizzato soltanto dal fondatore del canale.

N.B. Questo comando potrebbe essere stato disabilitato per
il tuo canale; in questo caso dovrai usare la lista di
accesso. Digita /msg ChanServ HELP ACCESS per
maggiori informazioni, e /msg ChanServ HELP SET XOP
per scoprire come passare da un sistema all'altro.
Sintassi:
/msg ChanServ VOP #canale ADD nick
/msg ChanServ VOP #canale DEL { nick | numero | lista }
/msg ChanServ VOP #canale LIST [ mask | lista ]
/msg ChanServ VOP #canale CLEAR
Esempio:
/msg ChanServ VOP #ChanGratis ADD GrandePuffo


Memoserv

I Comandi di MemoServ
MemoServ è un servizio che permette agli utenti di scambiarsi messaggi tra loro, anche quando il destinatario non è connesso alla rete IRC. Per poter utilizzare MemoServ è necessario che il proprio nickname e quello del destinatario siano registrati con NickServ e confermati.

È inoltre possibile inviare messaggi ai canali, che verranno letti dal fondatore e dalle categorie di operatori a cui si decide di inoltrare il messaggio, funzionalità che può essere molto utile per mettere in comunicazione i frequentatori di un canale con i suoi gestori.
  • CANCEL - Annulla l'ultimo memo inviato
  • CHECK - Controlla se l'ultimo memo ad un nick è stato letto
  • DEL - Cancella uno o più memo
  • HELP - Mostra questa lista e da informazioni sui comandi
  • IGNORE - Gestisce la lista ignore dei memo
  • INFO - Mostra informazioni sui tuoi nuovi memo
  • LIST - Mostra la lista dei propri memo
  • READ - Legge uno o più memo
  • SEND - Invia un memo a un nick o a un canale
  • SET - Imposta le opzioni relative ai memo
Per maggiori informazioni, una volta connessi alla rete IRC, digitare: /msg MemoServ HELP
(*) Di default, qualsiasi utente con almeno livello 10 (SOP) su un canale può leggere i memo di quel canale. Questo livello minimo può essere impostato con il comando LEVELS di ChanServ.


CANCEL

MemoServ - CANCEL
Questo comando annulla l'ultimo memo inviato al nick o al canale specificato, sempre che non sia già stato letto prima dell'uso di questo comando.

Sintassi:
/msg MemoServ CANCEL { nick | canale } numero
Esempio:
/msg MemoServ CANCEL Pippo
/msg MemoServ CANCEL #GlobalIRC


CHECK

MemoServ - CHECK

Controlla se l'ultimo memo che hai inviato al nick è stato letto oppure no.

Nota: che questo funziona unicamente coi nick, non coi canali.

Sintassi:
/msg MemoServ CHECK nick


DEL

MemoServ - DEL
Elimina il memo o i memo specificati. Si possono indicare numei multipli di memo o intervalli di numeri invece di un numero singolo, come nel secondo esempio.
Se viene usato LAST elimina l'ultimo memo.
Se viene usato ALL elimina tutti i memo.
Esempi:
DEL 1
Elimina il primo memo.
DEL 2-5,7-9
Elimina i memo che hanno numero numeri tra 2 e 5 e
tra 7 e 9, conservando quindi il 6.


HELP

MemoServ - HELP
È il comando per ottenere help on-line sul servizio MemoServ.

Sintassi:
/msg MemoServ HELP [comando]
Esempi:
/msg MemoServ HELP
/msg MemoServ HELP SEND


IGNORE

MemoServ - IGNORE
Questo comando ti permette di ignorare utenti per nick o host dalla ricezione di memo a te stesso o ad un canale.
Se qualcuno presente nella lista ignore dei memo prova ad inviati un memo o ad inviarlo al canale, non riceverà notifica
che lo hai ignorato.
Sintassi:
/msg MemoServ IGNORE #canale ADD nickname
/msg MemoServ IGNORE #canale DEL nickname
/msg MemoServ IGNORE #canale LIST


INFO

MemoServ - INFO
Mostra le informazioni sul numero di memo che hai, quanti memo non sono ancora stati letti e quanti memo puoi avere in totale. Se viene specificato un canale, mostra le stesse informazioni, ma relative al canale indicato.
Sintassi:
/msg MemoServ INFO [canale]


LIST

MemoServ - LIST
Questo comando mostra le proprie memo. Quando viene specificato NEW, mostra soltanto i nuovi memo (non letti). I memo non letti sono segnati con un "*" a sinistra del numero d'ordine. Si può anche indicare una lista di numeri, come in quest'esempio:
LIST 2-5,7-9
Mostra i memo che hanno numeri tra 2 e 5 e tra 7 e 9,
escludendo quindi il 6.

Sintassi:
/msg MemoServ LIST [CHANNEL] [LIST|NEW]

CHANNEL mostra solo i memo inviati a canali.

LIST mostra la lista dei memo.

NEW mostra solo i memo nuovi (non letti).

Senza parametri vengono mostrati tutti i memo.

Esempi:
/msg MemoServ LIST
/msg MemoServ LIST #CANALE LIST
/msg MemoServ LIST #CANALE NEWS


READ

MemoServ - READ
Legge il contenuto di un messaggio. Mostra il testo dei propri memo specificati. Se viene indicato LAST, mostra l'ultimo memo ricevuto. Se viene indicato NEW, mostra tutti i nuovi memo. Altrimenti, mostra il memo che ha numero numero. Si può anche specificare una lista di numeri, come nell'esempio:
READ 2-5,7-9
Mostra i memo che hanno numeri tra 2 e 5 e tra 7 e 9,
escludendo quindi il 6.
Sintassi:
/msg MemoServ READ [CANALE] { NUMERO | LISTA | LAST | NEW }
Esempi:
/msg MemoServ READ 3
/msg MemoServ READ #CANALE NUMERO - LISTA - LAST - NEW


SEND

MemoServ - SEND
Questo comando permette di inviare dei brevi messaggi (max 400 caratteri) ad altri utenti registrati con NickServ ma anche ai founder dei canali registrati. Il destinatario verrà notificato dell'arrivo del messaggio a seconda delle sue impostazioni di NOTIFY.

Sintassi:
/msg MemoServ SEND nickname/canale messaggio
Esempio:
/msg MemoServ SEND Nicola Devo dirti una cosa. Querami appena puoi
/msg MemoServ SEND #GlobalIRC Contattami ho un problema da risolvere


SET

MemoServ - SET
Permette di configurare le opzioni di MemoServ. Per poter utilizzare questo comando bisogna essere identificati al proprio nick.
  • NOTIFY - Permette di scegliere quando si vuole essere notificati della presenza di nuovi memo.
    Sintassi: /msg MemoServ SET NOTIFY ON
    /msg MemoServ SET NOTIFY LOGON
    /msg MemoServ SET NOTIFY NEW
    /msg MemoServ SET NOTIFY MAIL
    /msg MemoServ SET NOTIFY NOMAIL
    /msg MemoServ SET NOTIFY OFF

    ON La notifica avviene all’identificazione del nick e all’invio del memo.
    LOGON La notifica avviene solo all’identificazione del nick.
    NEW La notifica avviene all’invio del memo.
    MAIL La notifica viene effettuata tramite e-mail.
    NOMAIL La notifica via e-mail viene sospesa.
    OFF Nessuna notifica.

    Esempi: /msg MemoServ SET NOTIFY ON
    /msg MemoServ SET NOTIFY NEW
  • LIMIT - Imposta il numero massimo di memo che un utente (nick) o
    canale può avere. Impostare il limite a 0 fa in modo che
    l'utente (o il canale) non possa ricevere alcun memo;
    impostarlo a NONE fa sì che l'utente (o il canale) possa
    ricevere e conservare un numero indefinito di memo. Se non
    viene specificato nessun nick o canale, viene impostato il
    proprio limite.

    Aggiungere il parametro HARD fa in modo che l'utente non
    possa cambiare il limite. Non aggiungerlo ha il livello
    opposto, e permette all'utente di cambiarlo, anche se un
    limite precedente era stato impostato con HARD.

    Questo uso di SET LIMIT è limitato ai Services admin.
    Gli altri utenti possono impostare il limite soltanto per
    se stessi o per i canali sui quali hanno abbastanza
    privilegi, e potrebbero non essere in grado di rimuovere
    il limite o di impostarlo a un valore maggiore di 20.

Sintassi:
/msg MemoServ SET LIMIT [utente | canale] {limite | NONE} [HARD]


SeenServ **

I Comandi di SeenServ ( * )
SeenServ è un servizio che permette di sapere quando un certo utente si è collegato per l'ultima volta
  • HELP – Help on-line del servizio SeenServ
  • SEEN - Ricerca un nick specifico nel database
  • SEENNICK – Simile al comando seen ma fornisce più dettagli
La lingua dei messaggi di SeenServ è legata all’IP con cui ci si connette.

È possibile avere informazioni solo sulle connessioni avvenute negli ultimi 7 giorni.

Per maggiori informazioni, una volta connessi alla rete IRC, digitare: /msg SeenServ HELP
(*) Questi comandi potrebbero non essere attivi. Se non funzionano, utilizzate il servizio BotServ


SeenServ - HELP
È il comando per ottenere help on-line sul servizio SeenServ.

Sintassi:
/msg SeenServ HELP [comando]
Esempi:
/msg SeenServ HELP
/msg SeenServ HELP SEENNICK


SeenServ - SEEN
Permette di ricercare un nick all’interno del database (Non sono possibili ricerche con mask o parti del nick).

Sintassi:
/msg SeenServ SEEN nickname
Esempio:
/msg SeenServ SEEN Martin


SeenServ - SEENNICK
Permette di ottenere informazioni sull'ultima volta in cui è stato visto un determinato utente, fra cui quando è stato visto, l'ultimo indirizzo usato, e se era identificato al nick che stava usando e se ha cambiato nick. Non è però possibile sapere quale sia il nuovo nick, per motivi di privacy.

Sintassi:
/msg SeenServ SEENNICK nickname
Esempio:
/msg SeenServ SEENNICK ^Norad^


BotServ

I Comandi di BotServ

BotServ ti permette di avere un Bot nel tuo canale. E' un servizio pensato per gli utenti che non possono mantenere un bot.

I comandi disponibili sono i seguenti:

  • ACT Invia un /me al canale;

  • ASSIGN Assegna un Bot al canale;

  • BADWORDS Gestisce la lista delle parolacce;

  • BOT Consente agli operatori dei servizi di creare, modificare e eliminare i bot;

  • BOTLIST Mostra la lista dei Bot disponibili;

  • HELP È il comando per ottenere help on-line sul servizio BotServ;

  • INFO Mostra informazioni su un Bot o su un canale;

  • KICK Configura i kick;

  • SAY Fà sì che il Bot dica qualcosa in canale;

  • SET Imposta le opzioni del Bot;

  • UNASSIGN Rimuove il Bot da un canale.

Sintassi per vedere i comandi:
/msg BotServ help

Per usare i comandi usa:
/msg BotServ comando

Esempio:
/msg BotServ BOTLIST


ACT

BotServ - ACT

Fà sì che il bot faccia in canale l'equivalente di un "/me" utilizzando un testo specificato.

Sintassi:
/msg BotServ ACT #canale testo

Esempio:
/msg BotServ ACT #GlobalIRC Ciao!


ASSIGN

BotServ - ASSIGN

Assegna il bot con il nick specificato al canale indicato. Dopo averlo assegnato, il bot può essere configurato in base alle proprie necessità.

Sintassi:
/msg BotServ ASSIGN canale nick-del-bot

Esempio:
/msg BotServ ASSIGN #GlobalIRC Security


BADWORDS

BotServ - BADWORDS

Gestisce la lista delle parolacce in un canale. La lista delle parolacce indica quali parole devono attivare un kick se i kick per chi dice le parolacce sono attivi.

Sintassi:
/msg BotServ BADWORDS canale ADD parola [ SIINGLE | START | END ]
/msg BotServ BADWORDS canale DEL { parola | numero | lista }
/msg BotServ BADWORDS canale LIST [ MASK | LIST ]
/msg BotServ BADWORDS canale CLEAR

Per maggiori informazioni digita /msg BotServ HELP KICK BADWORDS


BOT

BotServ - BOT

Consente agli operatori dei servizi di creare, modificare e eliminare i bot
che gli utenti saranno in grado di utilizzare nei loro canali.

Comandi disponibili

  • BOT ADD aggiunge un bot con il nickname, il nome utente, hostname e realname. Poiché non vengono effettuati controlli di integrità per queste impostazioni, bisogna fare attenzione.
  • BOT CHANGE consente di modificare il nickname, il nome utente, il nome host o nome reale di un bot senza cancellarlo (e tutti i dati associati ad esso).
  • BOT DEL elimina il bot dato dalla lista.

Nota: Non è possibile creare un bot con un nick che è attualmente registrati. Se un utente sta usando un nickname non registrato, sara disconnesso.

Sintassi:
/msg BotServ BOT ADD nick user host real
/msg BotServ BOT CHANGE oldnick newnick [user [host [real]]]
/msg BotServ BOT DEL nick


BOTLIST

BotServ - BOTLIST

Con questo comando, è possibile visualizzare la lista dei Bot disponibili.

I bot con prefisso * sono riservati per il Network.

Sintassi:
/msg BotServ Botlist


HELP*

BotServ - HELP
È il comando per ottenere help on-line sul servizio BotServ.

Sintassi:
/msg BotServ HELP [comando]
Esempi:
/msg BotkServ HELP
/msg BotServ HELP SET
/msg BotServ HELP BADWORDS


INFO

BotServ - INFO

Permette di le informazioni di BotServ relative a un canale o a un bot. Se il parametro mostrerà il nick di un bot, mostrerà le informazioni relative alla data di creazione e al numero di canali a cui è assegnato.

Sintassi:
/msg BotServ INFO { canale | nick-del-bot }

Esempio:
/msg BotServ INFO Security


KICK

BotServ - KICK

Configura i kick del bot, l'opzione può essere:

  • BOLDS Imposta se il bot kicka chi usa il grassetto;
  • BADWORDS Imposta se il bot kicka chi dice le parolacce;
  • CAPS Imposta se il bot kicka chi scrive maiuscolo;
  • COLORS Imposta se il bot kicka chi usa i colori;
  • FLOOD Imposta se il bot kicka chi flooda;
  • REPEAT Imposta se il bot kicka chi ripete la stessa cosa;
  • REVERSES Imposta se il bot kicka chi usa il reverse;
  • UNDERLINES Imposta se il bot kicka chi usa il sottolineato.

Sintassi:
/msg BotServ KICK canale opzione parametri

Esempio:
/msg BotServ KICK #canale CAPS ON


SAY

BotServ - SAY

Fa sì che il bot dica in canale il testo specificato.

Sintassi:
/msg BotServ SAY #canale testo


SET

BotServ - SET

Configura le opzioni del Bot assegnato al canale:

  • DONTKICKOPS Protegge gli OP dai kick del Bot:
    Attiva o disattiva la protezione degli op sul canale. Quando è attiva, gli op non saranno kickati dal bot, anche se non hanno accesso di livello NOKICK;
  • DONTKICKVOICES Protegge i Voice dal kick del Bot:
    Attiva o disattiva la protezione dei voice sul canale. Quando è attiva, i voice non saranno kickati dal bot, anche se non hanno accesso di livello NOKICK;
  • FANTASY Attiva i comandi di "Fantasia":
    Attiva o disattiva l'uso dei comandi di fantasia sul canale. Quando è attivo, gli utenti potranno usare sul canale i comandi !op, !deop, !voice, !devoice, !kick, !kb, !unban, !seen, eccetera. Divertiti a scoprire gli altri comandi; provali sia specificando un nick che da soli, e aggiungi un motivo ad alcuni.
    Gli utenti che vogliono usare i comandi di fantasia DEVONO avere privilegi sufficienti sia per il livello FANTASIA che per il livello del comando richiesto (ad esempio, per usare !op, l'utente deve avere privilegi sufficienti anche per il livello OPDEOP);
  • GREET Attiva i messaggi di saluto (greet):
    Attiva o disattiva il saluto (greet ) sul canale. Quando è attivo, il bot mostrerà la riga di saluto degli utenti che entrano, se hanno privilegi sufficienti.
    Per impostare il messaggio di saluto, è necessario usare l'opzione SET GREET di NickServ;
  • SYMBIOSIS Fa in modo che il bot si comporti come un bot reale:
    Attiva o disattiva la modalità symbiosis sul canale. Quando è attiva, il bot farà tutto quello che normalmente sarebbe fatto da ChanServ sui canali, come l'impostazione dei MODI, l'invio dei KICK, la visualizzazione del messaggio di ingresso, eccetera.

Sintassi:
/msg BotServ SET canale opzione parametri

Esempio:
/msg BotServ SET #canale GREET { ON | OFF }


UNASSIGN

BotServ - UNASSIGN

Rimuove il bot da un canale. Dopo aver usato questo comando, il bot non entrerà più nel canale, ma la sua configurazione resterà salvata, in modo da non dover riconfigurare tutto di nuovo nel caso se ne assegni uno di nuovo.

Sintassi:
/msg BotServ UNASSIGN #canale


HostServ

I Comandi di HostServ

HostServ ci permette di abbinare al nostro nickname una Virtual Host
in alternativa alla mask numerica che ci viene assegnata alla connessione.

I comandi disponibili sono i seguenti:

  • GROUP Associa il vhost a tutti i nick del gruppo;

  • HELP Help on-line;

  • OFF Disattiva il vhost assegnato;

  • ON Attiva il vhost assegnato;

  • REQUEST Richiede il tuo vhost.

Per ulteriori informazioni, siete invitati ad entrare nel canale #Vhost

Sintassi per vedere i comandi:
/msg HostServ help

Per usare i comandi usa:
/msg HostServ comando

Esempio:
/msg HostServ REQUEST


GROUP

HostServ - GROUP

Sincronizza il tuo vHost per i Nick del gruppo

Questo comando permette agli utenti di impostare il vhost
del loro nick ATTUALE come vhost di tutti i nick dello stesso gruppo.

Sintassi:
/msg HostServ GROUP


HELP

HostServ - HELP
È il comando per ottenere help on-line sul servizio HostServ.

Sintassi:
/msg HostServ HELP [comando]
Esempi:
/msg HostServ HELP
/msg HostServ HELP GROUP
/msg HostServ HELP REQUEST


OFF

HostServ - OFF

Disattiva il tuo vHost

Disattiva il vhost attualmente assegnato al nick in uso.
Quando usi questo comando, ogni utente che effettua un
/whois su di te vedrà il tuo vero indirizzo IP.

Sintassi:
/msg HostServ OFF


ON

HostServ - ON

Attiva il tuo vHost

Attiva il vhost attualmente assegnato al nick in uso.
Quando usi questo comando, ogni utente che effettua un
/whois su di te vedrà il vhost invece che il tuo vero indirizzo IP.

Sintassi:
/msg HostServ ON


REQUEST

HostServ - REQUEST

Richiede un vHost per il tuo Nick

Richiede l'attivazione del vHost specificato per il tuo nick da parte
degli amministratori di rete. Sei pregato di pazientare
finchè la tua richiesta viene elaborata.

Sintassi:
/msg HostServ REQUEST vhost

Esempio:
/msg HostServ REQUEST Pinco.Pallino.GlobalIRC.it


Modes
Su GlobalIRC sono disponibili vari modi utente e canale:
  • User Modes – Modi utente disponibili
  • Channel Modes – Modi canale disponibili


User Modes

Modes - User Modes
Mode | Descrizione
A | (IRCOp Only) Identifica un Amministratore del Server
a | (IRCOp Only) Identifica un Amministratore dei Servizi
B | Segna il nick come BOT
C | (IRCOp Only) Identifica un Co-Amministratore del Server
d | Con questa flag, non si ricevono messaggi in privato dai canali (con l'eccezione di testo preceduto da alcuni caratteri )
D | Non vengono ricevuti messaggi privati e notice, tranne che dalle U:Lines e IRCOperator
G | Filtra tutte le parole brutte (badwords) per configurazione
g | (IRCOp Only) E' possibile inviare e leggere, i messaggi inviati a tutti gli IRCOP globali e locali
H | (IRCOp Only) Nasconde lo stato di IRCOP
h | (HELPOp Only) Identifica un operatore disponibile per aiuto ( sul canale #IRCHELP )
I | Per nascondere il tempo di inattività di un oper (in /whois) da utenti regolari.
i | Rende il nick invisibile agli utenti che eseguono il comando /names o il comando /who.
N | (IRCOp Only) Identifica un Amministratore della Network
O | (IRCOp Only) Identifica un IRC Operator Locale
o | (IRCOp Only) Identifica IRC Operator Globale
p | Nasconde il canale dove si trova il nick effettuando il /whois
q | (IRCOp Only) Solo le U:Lines possono kickare il nick
R | E' possibile ricevere Notice e messaggi privati solamente dagli utenti con nick registrato ( +r )
r | Identifica un nick registrato
S | (IRCOp Only) Utilizzato per proteggere i Services Daemons
s | Rende possibile leggere i notice del server
T | Impedisce di ricevere CTCP
t | Dice che stai utilizzando un /vhost
V | Contrassegna il nick come utente WebTV
v | (IRCOp Only) Rigetta DCC infetti con un notice
W | (IRCOp Only) Ricevi un notice quando gli utenti ti fanno un /whois
w | Puoi leggere i messaggi wallops ( +w )
x | Nasconde l'hostname dell'utente
z | Indica che stai usando una connessione protetta SSL

Sintassi: /umode [+|-modes]
oppure /mode nick [+|-modes]

Esempi:
/mode pippo +w-i
/mode pippo (per vedere i modes impostati sul proprio nick)


Channel Modes

Modes - Channel Modes
Mode | Param | Descrizione
A |  | Solo gli amministratori possono entrare nel canale.
a | nick | Rende l'utente un amministratore del canale.
b | nick!user@host | Permette di bannare una mask nel formato nick!user@host (o anche solo un nick) da un canale.
c |  | Nessun colore ANSI può essere inviato al canale
C |  | Impedisce di inviare CTCP al canale.
e | nick!user@host | Eccezione dal ban - Se qualcuno corrisponde a questi parametri, possono entrare in un canale, anche se corrispondono a un ban esistente.
f | numero tipo: secondi | Protegge il canale dal flood.
G |  | Verifica la presenza di parole elencate nei blocchi delle parolacce, e li sostituisce con <censored> .
h | nick | Fornisce lo stato halfop all'utente.
i |  | Rende il canale solo ad invito.
I | nick!user@host | Invita eccezioni ("Invex") - se qualcuno corrisponde a questo, possono bypassare il mode +i .
j | entrate:secondi | Regola le entrate degli utenti secondo per secondo.
K |  | Il comando /knock #canale messaggio, non sarà permesso.
k | chiave | Rende il canale protetto da password.
l | numero | Setta il massimo numero di utenti che possono stare nel canale.
L | canale | Se è stato raggiunto in numero stabilito dal +l, gli utenti saranno inviati a questo canale.
M |  | E' richiesto un nickname registrato (+r) per poter parlare/scrivere.
m |  | Rende il canale moderato: solo i +o, +h e +v possono parlare/sctivere.
N |  | Non permette il cambio di nickname.
n |  | Proibisce l'invio al canale di messaggi dall'esterno.
O |  | (IRCop Only) Permette l'ingresso al canale, solo agli IRC Operators.
o | nick | Permette di settare un nickname, come operatore del canale ( @ ).
p |  | Rende il canale privato (non appare nei /WHOIS, il topic e' nascosto nei /LIST).
q | nick | Setta il fondatore del canale.
Q |  | Solo le U:Lines del server, possono kickare un utente
r |  | (Services Only) Contraddistingue un canale registrato con ChanServ.
R |  | Solo i nick registrati ( +r ), possono entrare nel canale.
S |  | Leva tutti i colori in entrata.
s |  | Rende il canale segreto (non appare nei /WHOIS o nei /LIST).
t |  | Solamente gli operatori, possono cambiare il topic del canale.
T |  | Non sono ammessi NOTICE nel canale.
u |  | Auditorium - Rende /names e /who nel #canale visibile solo agli operatori/moderatori ( @ )
V |  | Impedisce di utilizzare il comando /invite .
v | nick | Concede ad un nickname il diritto di voce, su un canale moderato (+m).
z |  | Possono entrare nel canale, solo gli utenti connessi tramite SSL connessione sicura.
Z |  | Settato dal server, ad indicare che tutti gli utenti nel canale hanno una connessione sicura (SSL). Quando attiva, viene impostato +z . Ulines (ad esempio: BotServ) vengono ignorati quando il conteggio "utenti non sicuri". E' settato dai Server Admin, per rendere sicuro il collegamento tra server a server link (che potrebbe essere, con l'aiuto di SSL, ma anche VPN, interfaccia di loopback, la crittografia quantistica, etc etc), il IRCd non e non in grado di rilevare questo.
Il mode j non è al momento supportato dai servizi.
Sintassi: /mode #canale [+|-modes [parametri]
Esempi:
/mode #baruffa +mi
/mode #IRCHelp +l 10238
/mode #Io&Te +k finalmentesoli
/mode #hack +m-si
/mode #Operhelp +b *pippo@*interbusiness.it
/mode #Lilliput +o Gulliver
/mode #Soleluna (per vedere i mode impostati)
/mode #Italia +b (per vedere i ban impostati)


Varie
Una breve guida per spiegare come risolvere alcuni dei problemi più comuni che gli utenti potrebbero rilevare.
  • Comandi IRC – I comandi utente dell’IRC daemon di GlobalIRC
  • Help Ident - Un'errata configurazione dell'Ident potrebbe impedire la connessione
  • Help DCC - Alcuni trasferimenti di files possono venire bloccati dal server
  • Maschere di riconoscimento – A cosa servono e come si determinano le mask
  • Dettagli di GlobalIRC – Particolarità della rete
  • I Server di GlobalIRC – Server linkati ed indirizzi
  • Link utili – Aiuti e informazioni su GlobalIRC
Per maggiori informazioni, una volta connessi al network digitare: /join #IRCHelp


Comandi IRC

Varie - Comandi IRC
ADMIN
Fornisce informazioni amministrative sul server. Se dest è specificato, la risposta verrà fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /ADMIN [dest]
Esempi:
/ADMIN
/ADMIN fedora.globalirc.it
/ADMIN peace*
AWAY
Se il messaggio è specificato, mette in away e il messaggio appare nel whois; altrimenti rimuove lo stato di away.
Sintassi: /AWAY [:messaggio]
Esempi:
/AWAY Sto lavorando, non disturbare
/AWAY
DCCALLOW
Aggiunge o rimuove nick dalla lista di DCC permesse. Chi è su questa lista potrà mandarti file con estensioni normalmente bloccate dal server. Con l’opzione list viene fornita la lista delle persone al momento sulla tua DCC allow list. L’opzione help fornisce informazioni analoghe a quanto detto qui.
Sintassi: /DCCALLOW +|-nick[,+|-nick ...]
/DCCALLOW LIST
/DCCALLOW HELP
Esempi:
/DCCALLOW +Mirtilla,+Antonio
/DCCALLOW –Robert
/DCCALLOW LIST
HELP
Fornisce la lista dei comandi disponibili, uno per riga.
Sintassi: /HELP
INFO
Fornisce informazioni sul server a cui sei connesso, o su un server remoto se è specificato in dest: può essere indicato un nick o l'indirizzo di un server.
Sintassi: /INFO [dest]
Esempi:
/INFO
/INFO windows.globalirc.it
INVITE
Invita nick nel canale specificato.
Sintassi: /INVITE nick #canale
Esempio:
/INVITE kavia #radioitalia
ISON
Fornisce la lista dei nick indicati che sono al momento online, se ce ne sono.
Sintassi: /ISON nick[ nick ...]
Esempi:
/ISON ^Norad^
/ISON Mirtilla ^Ruby^ Casper
JOIN
Cerca di entrare nel(i) canale(i) specificato(i), con la(e) chiave(i) specificata(e), se richiesta(e). Ogni chiave corrisponde ad un canale nella stessa posizione nella lista; per esempio "JOIN #c1,#c2,#c3 k2,k3" non è corretto se le chiavi k2 e k3 sono per #c2 e #c3, rispettivamente. Invece "JOIN #c1,#c2,#c3 k1,k2" è corretto se i primi due canali richiedono le chiavi indicate. Specificando 0 come nome del canale si ottiene l’uscita da tutti i canali in cui si è.
Sintassi: /JOIN #canale[,#canale ...] [key[,key ...]]
Esempi:
/join #Italia
/join #Soleluna,#IRCHelp
/join #SoloNoi paperotto
/join #Antipatici,#Macedonia war54,ciliegia
KICK
Espelle il(i) nick specificato(i) dal(i) canale(i) specificato(i), con un motivo opzionale. I kick vengono eseguiti per tutti i nick indicati in tutti i canali indicati.
Sintassi: /KICK #canale[,#canale ...] nick[,nick ...(2)] [:motivo]
Esempi:
/kick #IRCHelp ^L4m3r^ Non disturbare
/kick #Soleluna,#Liberozone,#Italia warBoT Niente guerra qui
LINKS
Fornisce la lista dei server al momento connessi alla rete. Se viene specificata una mask vengono forniti solo i link che corrispondono. Se viene specificato dest la richiesta viene inviata al server remoto indicato.
I colori distinguono i server allo stesso “livello”, cioè server con lo stesso hopcount saranno rappresentati con lo stesso colore.
Hopcount è il numero di “salti” che occorre fare per raggiungere quel dato server partendo dal server a cui si è connessi o dal server dest specificato.
Sintassi: /LINKS [dest][mask]
Esempi:
/LINKS
/LINKS centos.globalirc.it *.globalirc.it
LIST
Fornisce la lista dei canali aperti.
Sintassi: /LIST [opzioni]
Le opzioni disponibili sono:
>utenti - fornisce la lista dei canali con almeno un numero di utenti superiore ad utenti
<utenti - fornisce la lista dei canali con un numero di utenti inferiore ad utenti
mask - fornisce la lista dei canali il cui nome corrisponde alla mask fornita
!mask - fornisce la lista dei canali il cui nome non corrisponde alla mask fornita
canale - la lista comprende solo il canale indicato
Esempi:
/LIST
/LIST >30
/LIST <50
/LIST >1 <20
/LIST *musica*
/LIST #Soleluna
LUSERS
Fornisce statistiche sull’utenza. Se viene specificato dest, la risposta verrà fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server. Il secondo parametro (*) non ha significato ma viene mantenuto per compatibilità con versioni precedenti.
Sintassi: /LUSERS [* dest]
Esempi:
/LUSERS
/LUSERS * london.globalirc.it
MODE
Modifica i modi utente (se specificati) e fornisce i modi utente correnti. nick deve essere il nick di chi esegue il comando. Un '+' attiva il modo, mentre un '-' lo disattiva. I modi possono essere associati, ad esempio: "/MODE mynick +i-wg+s" (attiva i modi 'i' e 's', e disattiva i modi 'w' e 'g'). Si possono settare al massimo 6 modi per comando.
Sintassi: /MODE nick [+|-modes]
Esempi:
/mode ^Norad^ +w-i
/mode ^Norad^
MODE
La stessa cosa di quanto visto sopra, ma per i canali. Alcuni modi canale richiedono parametri, che sono separati da spazi.
Sintassi: /MODE #canale [+|-modes [parametri]]
Esempi:
/mode #IRCHelp +l 10526
/mode #Io&Te +k finalmentesoli
/mode #hack +m-si
/mode #Operhelp +b *pippo@*interbusiness.it
/mode #Lilliput +o Gulliver
/mode #Soleluna (per vedere i mode impostati)
/mode #Italia +b (per vedere i ban impostati)
MOTD
Fornisce il Messaggio Del Giorno (Message Of The Day). Se viene specificato dest, la risposta viene fornita dal server specificato che può essere un nick o l'indirizzo di un server.
Sintassi: /MOTD [dest]
Esempi:
/MOTD
/MOTD fedora.globalirc.it
NAMES
Fornisce la lista dei client presenti nel canale specificato, con l’indicazione eventuale dello stato di op o voice. I nomi nei canali +s vengono forniti solo se si è in quel momento presenti nel canale; stessa cosa vale per i client settati +i (invisibili).
Sintassi: /NAMES #canale
Esempio:
/NAMES #Liberozone
NICK
Cambia il tuo nickname.
Sintassi: /NICK nickname
Esempio:
/NICK ^Norad^
NOTICE
Può essere usato per inviare notice (avvisi) al nick specificato (o a una lista di nick). Se è specificato il nome del server del destinatario l’avviso sarà inviato solo se il nick è connesso a quel server. È una misura di sicurezza, soprattutto per i services del network.
Può anche essere usato per inviare notice al canale specificato (o a una lista di canali). Se il nome del canale è preceduto dal carattere '@', l’avviso sarà inviato a tutti gli op del canale. In modo simile, con il simbolo '+' l’avviso sarà diretto a tutti i voice, e ad entrambi se sono presenti i due simboli insieme.
Sintassi: /NOTICE nick[@nomeserver][,nick[@nomeserver] ...(18)] :messaggio
/NOTICE [@][%][+]#canale[,[@][%][+]#canale ...(18)] :messaggio
Esempi:
/NOTICE Rodolfo Stammi lontano che non voglio parlarti
/NOTICE Mirtilla,Casper,Antonio Facciamo un quiz?
/NOTICE #Liberozone Buonasera!
/NOTICE @+#IRCHelp Ci vediamo domani
PART
Consente di uscire dal #canale con un messaggio opzionale.
Sintassi: /PART #canale[,#canale ...] [:messaggio]
Esempi:
/PART #Italia A dopo!
/PART #Soleluna,#italia esco, ci vediamo
PRIVMSG
Può essere usato per inviare un messaggio al nick specificato (o a una lista di nick). Se viene specificato il nome del server di destinazione, il messaggio sarà inviato solo se il nick è connesso al server indicato. È una misura di sicurezza, soprattutto per i services del Network.
Pùò anche essere usato per inviare un messaggio ad un canale specificato (o ad una lista di canali). Se il nome del canale è preceduto dal carattere '@', il messaggio sarà inviato a tutti gli op del canale. In modo simile, con il simbolo '+' il messaggio sarà diretto a tutti i voice, e ad entrambi se sono presenti i due simboli insieme.
Sintassi: /PRIVMSG nick[@nomeserver][,nick[@nomeserver] ...(18)] :messaggio
/PRIVMSG [@][%][+]#canale[,[@][%][+]#canale ...(18)] :messaggio
Esempi:
/PRIVMSG Martin Ti va di chiacchierare?
/PRIVMSG _ZIP_,Jenny Sono tornato!
/PRIVMSG #Baraonda Buonasera!
/PRIVMSG @%+#italia Ciao
QUIT
Disconnette da IRC, con un commento opzionale.
Sintassi: /QUIT [:commento]
Esempi:
/QUIT
/QUIT Torno dopo
SILENCE
Aggiunge o toglie la mask nick!user@host specificata dalla silence list. Client che hanno una mask corrispondente ad una nella silence non potranno inviarti PRIVMSG o NOTICE. Se non viene specificata una mask, il comando fornisce un elenco delle mask presenti nella tua silence list. Nella lista possono essere presenti al massimo 10 mask. La lista si svuota alla disconnessione.
Sintassi: /SILENCE [+|-mask]
Esempi:
/SILENCE +*!*bau@*tiscali.it
/SILENCE –Casper!*@*
/SILENCE
STATS
Fornisce statistiche dal server. Se viene specificato dest, la risposta viene fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /STATS flag [dest]
Non ci sono flag disponibili per gli utenti
TIME
Fornisce l’ora locale del server. Se viene specificato dest, la risposta viene fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /TIME [dest]
Esempi:
/TIME
/TIME redhat.globalirc.it
TOPIC
Mostra il topic di un canale o lo cambia se ne viene specificato uno.
Sintassi: /TOPIC #canale [topic]
Esempi:
/TOPIC #Liberozone
/TOPIC #IRCHelp =A= |Official Help Channel di GlobalIRC Network| =A= NON aiutiamo su Script,Shell,Bot,BNC,IRCd,Fserv,DCC,altri Network, NO PARKING
USERS
Fornisce il numero di utenti locali e globali (correnti e massimi). Se viene specificato dest, la risposta verrà fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /USERS [dest]
Esempi:
/USERS
/USERS arm.globalirc.it
USERHOST
Fornisce informazioni sintetiche sul(i) nick specificato(i). Per prima cosa il nickname, seguito da un '*' se è un IRCop, il carattere '=', '-' se away ('+' se non lo è), username@hostname. Risposte multiple sono separate da spazi.
Sintassi: /USERHOST nick[ nick ...(3)]
Esempi:
/USERHOST Casper,Mirtilla,Alberto
/USERHOST ^Norad^
> ^Norad^*=-Norad@birillo.tiscali.com
VERSION
Fornisce informazioni sulla versione dell’IRCd per il server a cui sei connesso, o per un server remoto se specificato. Se viene specificato dest, la risposta verrà fornita dal server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /VERSION [dest]
Esempi:
/VERSION
/VERSION irc.globalirc.it
WATCH
Aggiunge o toglie il(i) nick specificato(i) dalla watch list. Verrai notificato quando qualcuno nella tua watch list si connette o si sconnette. Se non viene specificato un nick, verrà fornita la lista dei nick nella watch list al momento online. Lo stesso comando si usa per avere informazioni sulla propria watch list. Nella lista possono essere presenti al massimo 128 nick.
Sintassi: /WATCH [+|-nick][ +|-nick ...]
/WATCH [flag]
Flag disponibili sono:
c|C - pulisce la watch list
s|S - mostra lo stato generale
l - fornisce informazioni sui nick online al momento
L - fornisce informazioni su tutti i nick
Esempi:
/WATCH +Mirtilla
/WATCH C
/WATCH L
Normalmente questi comandi vengono gestiti dal client. In mIRC dal comando NOTIFY.
WHO
Fornisce informazioni sul nick, canale o utenti specificati.
Sintassi: /WHO nick
/WHO #canale
/WHO mask
/WHO +|-flags [parametri]

Specificando un nick o un canale fornisce le informazioni seguenti: canale nickname, username, hostname, server di connessione, hopcount cioè numero di server tra nick e chi da il comando, flag di stato, e real name, nel formato:
[server] [#canale] nickname H|G[S][*][@|%|+] user host :hopcount real_name
Specificando un canale fornisce informazioni su tutti i client in quel canale.
Mirc non mostra il server di connessione; il canale viene specificato solo se viene eseguito un /who #canale.
Le lettere H|G stanno a significare Here (presente) e Gone (away, non presente).
S è presente se l’utente usa una connessione SSL.
L’asterisco * contraddistingue gli IRCop.
@ % e + sono il livello di accesso al canale: Op, HalfOp o Voice.
Hopcount è il numero di “salti” di server che occorre fare per raggiungere quel dato utente.

Ad esempio: #irchelp ^Norad^ H*S @ ~Norad@birillo.tiscali.com :3 =^.^= Rauha =^.^=

Fornendo una mask: se la mask contiene un '.', viene confrontata con gli hostnames di tutti client online visibili (non settati +i); altrimenti viene confrontata con i nick di tutti i client online visibili. Vengono fornite informazioni su tutti i client per cui è stata trovata una corrispondenza.
I flag devono essere specificati come i modi utenti o canale – p.es. "-a+c" significa "non away" e "sul canale specificato". I flag sono i seguenti:
a |  | l’utente è away
C |  | mostra il primo canale visibile in cui è l’utente
M |  | cerca utenti nello stesso canale in cui sono io
c | #canale | l’utente è sul canale specificato (no wildcards)
h | mask | l’host dell’utente corrisponde alla mask
m | umodes | l’utente ha gli specificati usermodes (solo o/A/a)
n | mask | il nick corrisponde alla mask specificata
s | server | l’utente è sul server specificato (no wildcards)
u | mask | l’username dell’utente corrisponde alla mask specificata
Esempi:
/WHO ^Norad^
/WHO #Soleluna
/WHO +ch #italia *pool8250.interbusiness.it
WHOIS
Fornisce informazioni sul nick specificato (o su una lista di nick): nickname, username, hostname, real name, canali in cui è, server di connessione, info sul server di connessione, stato di registrazione del nick, stato di away, stato di IRC operator, modi utente e tempo di inattività (idle time) [Quest’ultima solo nel caso che l’utente sia sullo stesso server o che la richiesta venga fatta al server a cui è connesso, oppure mettendo il nick anche come dest]. Se viene specificato dest la richiesta è inviata al server indicato: può essere specificato un nick o l'indirizzo di un server.
Sintassi: /WHOIS [dest] nick[,nick ...]
Esempi:
/WHOIS Mirtilla
/WHOIS Antonio,Robert
/WHOIS Casper Casper
/WHOIS irc.globalirc.it Casper
WHOWAS
Fornisce le informazioni registrate sul nick specificato (o su una lista di nick) quando era online: nickname, username, hostname, real name, server di connessione, e ora di disconnessione (UTC). Se viene specificato max, le informazioni vengono fornite solo per le ultime max volte che il nick è stato usato; di default vengono fornite tutte. Se viene specificato dest, la richiesta è inviata al server remoto (le informazioni vengono limitate agli ultimi 20 casi): può essere specificato un nick o l'indirizzo di un server.
Sintassi: /WHOWAS nick[,nick ...] [max [dest]]
Esempi:
/WHOWAS ^Norad^
/WHOWAS Mirtilla,Casper
/WHOWAS Alfredo5 irc.globalirc.it
NOTA: I due punti (:) nella sintassi di alcuni comandi servono per far capire all’IRCd che quello che segue è di lunghezza indefinita; in realtà molti client elaborano i comandi per cui i due punti non sono necessari (e non sono stati inseriti negli esempi), anzi se vengono inseriti nel comando appaiono poi nel messaggio o nel motivo specificato.
Alcuni comandi inoltre vengono riconosciuti dai client come comandi propri. Per fare in modo che vengano passati al server senza essere processati dal client occorre anteporre /QUOTE al comando.
Esempi:
/QUOTE VERSION
/QUOTE HELP


Ident

Varie - Ident
Per una corretta connessione priva di problemi, potrebbe essere necessario abilitare l'IDENT server nelle opzioni di mIRC. Per abilitarla è necessario seguire questi semplici passi:
  • Accedere alle Opzioni, premendo contemporaneamente i tasti ALT ed O
  • Andare su Connect e poi su Identd
  • Barrare le casella di spunta Enable Ident server
  • Compilare il campo User ID con il proprio username
  • Compilare il campo System con il proprio sistema operativo (consigliato comunque impostarlo in UNIX)
  • Compilare il campo Port con la porta relativa all'Ident request (solitamente la 113)

Nota: un'errata impostazione dello User ID può impedire la connessione al server.
Sono infatti vietati User ID di un solo carattere che non sia una lettera dell'alfabeto (a...z) e User ID che contengano caratteri "strani" ($, @, !, e così via).

Se neanche con l'impostazione dell'Ident riuscite a collegarvi, dovete:

  • Accedere alle Opzioni, premendo contemporaneamente i tasti ALT ed O
  • Andare su Connect
  • Controllare che nel campo E-Mail Address non siano contenuti caratteri "strani" di cui sopra

Se neanche adesso riuscite a collegarvi, è colpa del vostro script che forza una sua ident che probabilmente contiene caratteri non ammessi. Sarete costretti a cambiare script oppure a digitare /remote off prima di collegarvi a un nostro server.


DCC

Varie - DCC
Per default, il server blocca il trasferimento in DCC di files con estensioni .JS, .PL, .EXE, .COM, .BAT, .DLL, .INI, .VBS, .PIF, .MRC, .SCR, .DOC, .XLS, .LNK, .SHS, .ZIP, .RAR, .ACE, .PHP, .ASP, .HTA, .HTM e .HTML in quanto probabili veicoli di virus e trojans. In questo caso chi invia il file avrà un messaggio di questo genere:

-world.globalirc.it- Per l'invio di files *.exe e' richiesta l'autorizzazione del ricevente. Fai sapere a NICK che deve digitare /DCCALLOW +NICK per poter ricevere questo file.

mentre chi dovrebbe riceverlo avrà una notice di questo tipo:

-world.globalirc.it- L'utente NICK (user@host) ha provato ad inviarti un file chiamato nomefile.exe. Per la ricezione di questo file e' necessaria la tua autorizzazione. Se hai la certezza che non si tratti di un file infetto, digita /DCCALLOW +NICK per riceverlo.

Nel caso comunque in cui il ricevente sia certo della sicurezza del file, è necessario utilizzare il comando /DCCALLOW per permettere la ricezione di files di quel tipo provenienti da un determinato nick.

Sintassi del comando DCCALLOW:
/DCCALLOW +nickmittente (permette la ricezione di file provenienti da nickmittente)
/DCCALLOW -nickmittente (blocca la ricezione di file sospetti provenienti da nickmittente)
/DCCALLOW LIST (visualizza la lista dei nick dai quali si consente la ricezione di file sospetti)

Nota: La DCCALLOW list si svuota ogni qualvolta vi disconnettete dal server. Inoltre, appena un utente presente nella vostra lista si disconnette dal server, viene automaticamente tolto dalla vostra lista.

Esempio:
nick1 invia via DCC file.exe a nick2
a nick1 verrà visualizzato il messaggio di cui sopra
nick2, per ricevere il file, dovrà digitare /DCCALLOW +nick1 e farsi inviare di nuovo il file
per togliere poi nick1 dalla lista, nick2 dovrà digitare /DCCALLOW -nick1


Maschere di riconoscimento

Varie - Maschere di riconoscimento
Spesso e volentieri i comandi di IRC e dei servizi chiedono come parametro una 'mask', e questo lascia interdetti coloro che non hanno dimestichezza al riguardo. Questo breve testo si propone di chiarire un po’ le idee su cosa sia una mask e come possa essere usata per identificare un utente o una connessione.

A ciascun utente su IRC è associata una mask, ossia un insieme di caratteri e numeri che caratterizzano la sua connessione al server.
Questa mask è visibile attraverso un certo numero di comandi, per esempio il whois. Dunque andiamo ad esaminare la maschera più nel dettaglio, richiedendo informazioni su un ipotetico nick 'pippo' con il comando /whois pippo.
Verrà fuori qualcosa di questo tipo:

pippo is carota@GlobalIRC-BC99E844.retail.telecomitalia.it
...
altre informazioni
...

La parte del whois che ci interessa è quella dove compare la mask (di solito una delle prime righe). La maschera è strutturata in tre parti:
nick!user@host

Come si può vedere un punto esclamativo separa il nick dall'user e una chiocciola separa l'user id dall'host. In particolare nel whois viene mostrata solo la parte user@host , senza il nick che del resto è lì vicino. Quindi riprendendo l'esempio precedente, la mask completa sarebbe:
pippo!carota@GlobalIRC-BC99E844.retail.telecomitalia.it

Dunque, così come possiamo fare riferimento ad un utente attraverso il suo nick (quello che siamo abituati a fare), per determinati scopi può far comodo fare riferimento alla sua maschera o, meglio ancora, a parte di essa.

Prendiamo per esempio un classico comando in cui si adopera la mask, il ban. Per bannare possiamo usare /mode #canale +b NICK , ma questo metterà semplicemente un ban sul nick, nella forma nick!*@*
Cosa siano quegli asterischi che sostituiscono gli altri due campi vuoti lo vedremo dopo.

In base a quanto detto prima, potremmo bannare utilizzando, invece che il nick, un'altra parte della maschera. Del resto un ban sul nick è piuttosto inefficace, visto che all'interessato basterà cambiare nick per rientrare sul canale.
Dunque ricaviamo la maschera del tizio (magari attraverso un whois) e usiamola per un ban. Immaginiamo che la mask sia sempre
pippo!carota@@GlobalIRC-BC99E844.retail.telecomitalia.it .

Scriviamo /mode #canale +b *!*@GlobalIRC-BC99E844.retail.telecomitalia.it
Questo è un ban più interessante. E' bene a questo punto spiegare cosa siano quegli asterischi. Il carattere * un 'carattere jolly' e il significato è 'qualunque cosa sia scritta al mio posto'. Quindi, quel ban si può leggere così:

effettua l'operazione (in questo caso il ban) su:
qualunque nick e qualunque user id che abbia come host @GlobalIRC-BC99E844.retail.telecomitalia.it

È facile immaginare che a questo punto al tizio non basterà cambiare nick per rientrare nel canale, visto che il ban è specificato con la * al posto del nick nella maschera, per cui il ban funziona su qualunque nick. Dovrà cambiarsi l'host, e questo nella migliore delle ipotesi significherà ricollegarsi ad internet, con tutti i disagi del caso (specie considerando che un ban si rimette in un attimo).

Analogamente potremmo mettere un ban di questo tipo:
/mode #canale +b *!carota@*

Se avete afferrato il concetto, avrete già interpretato in modo corretto nella vostra mente questo ban:

qualunque nick e qualunque host, che abbiano come userid carota

Immaginate cosa succederebbe mettendo un ban di questo tipo:
/mode #canale +b *!*@*

Bisognerebbe avere delle ragioni particolari per mettere una cosa del genere:
in effetti il suo significato è 'tutto': qualunque nick, qualunque user id, qualunque host. Applicando una maschera simile ad un ban il suo effetto sarebbe tener fuori tutti gli utenti da un canale.
È questa infatti la mask che usa ChanServ per bannare tutti gli utenti di un canale in caso di masskick.

Non è detto che un carattere jolly debba prendersi per forza un intero campo della maschera tutto per sé.. ci si può divertire molto di più, vediamo qualche esempio...

/mode #canale +b pi*!*@* , questo ban viene attivato su tutti quelli che hanno un nick che comincia per pi (con qualunque user id e qualunque mask). Quindi sia pippo che pirata e pikachu saranno tenuti fuori da un ban di questo tipo.

/mode #canale +b *pi*!*@* , questo ban viene attivato su tutti quelli che hanno un nick che contiene pi (con qualunque user id e qualunque mask). Per esempio saranno tenuti fuori pippo, bepi, arpia.

/mode #canale +b *p*i*!*@* , questo ban viene attivato su tutti quelli che hanno un nick che contiene le lettere 'p' e 'i' , in quell'ordine ma non per forza attaccate (con qualunque user id e qualunque mask). Per esempio saranno tenuti fuori pippo, pamila, serpi.

/mode #canale +b pippo!*@*carota.it , questo ban viene attivato su tutti quelli che hanno il nick pippo E hanno l'host che finisce per carota.it

/mode #canale +b man?!*@* , qui usiamo l'altro carattere jolly a nostra disposizione, ossia ? . Mentre * voleva dire 'qualunque cosa (anche nulla) al mio posto' , il carattere ? vuol dire 'un solo carattere o numero al mio posto (e deve esserci per forza)'. Dunque questo ban funzionerà come sempre su qualunque user id e qualunque host, che abbiano come nick mano , mani, mant , man5, man] . NON funzionerà invece su man oppure su manto. Questo perché il simbolo ? chiede un solo carattere al suo posto, e lo chiede in modo obbligatorio.

/mode #canale +b *!????@* , questo ban viene attivato su tutti quelli che hanno un ident di esattamente 4 caratteri, con qualunque nick e qualunque host.

Tutto questo l'abbiamo visto per il ban, ma è chiaro che tutto questo discorso è utile per definire un utente o un insieme di utenti che sono coinvolti in un qualsiasi comando che permetta l'uso di una mask.


Dettagli di GlobalIRC*

Varie - Dettagli di GlobalIRC IRC Network

L’IRCd utilizzato su GlobalIRC è InspIRCd-2.0 con supporto SSL (Secure Sockets Layer) e IPv6.

Su GlobalIRC gli stati possibili sono voice (+v), halfop (+h), op (+o), protect (+a) e owner (+q) contraddistinti rispettivamente da + , %, @ , & e ~.

Su GlobalIRC possono essere aperti solo #canali globali. E possono essere registrati.

Il nome del canale può essere al massimo di 64 caratteri, compreso il # iniziale.

È possibile entrare in un massimo di 20 canali contemporaneamente.

In un canale è possibile settare un massimo di 60 ban.

Nel nick sono ammessi i caratteri ascii da ALT+65 ad ALT+125, cioè le lettere maiuscole e minuscole ed i caratteri [ \ ] ^ _ ` { | } ; anche i numeri e – sono ammessi, ma non come primo carattere.

Un nick può essere lungo al massimo 30 caratteri, il realname al massimo 50.

L’User ID o ident può essere lungo al massimo 10 caratteri. Come primo carattere è presente ~ se non si dispone di un ident server.

L’host può essere lungo al massimo 63 caratteri; nel caso sia più lungo, compare l’IP (criptato o meno a seconda che sia impostata l’opzione +x sul nick oppure no).

Su GlobalIRC sono consentite 3 connessioni simultanee (cloni) dallo stesso IP. Alla quinta si viene akillati (bannati da GlobalIRC) per 10 minuti.

I topic e i messaggi di kick possono essere lunghi al massimo 307 caratteri, quelli di quit al massimo 301 (poiché il messaggio comprende “quit: ”).

Per quanto riguarda la lunghezza massima di messaggi e notice: il massimo consentito è 512 caratteri, ma in questi sono compresi anche quelli del comando stesso: “nick_mittente!user@host PRIVMSG nick_destinatario :”, nonché due caratteri di controllo finali.

Al momento della connessione sono riportati molti dati utili. Ad esempio:

london.globalirc.it
InspIRCd-2.0
BGHIRSWcdgiorswx
ABCDFGHMNOQRSTXZabcdefghijklmnopqrstvw
FHXZabdefghjkloqvw
AWAYLEN=200
CALLERID=g
CASEMAPPING=rfc1459
CHANMODES=XZbegw,k,FHdfjl,ABCDGMNOQRSTcimnprst
CHANNELLEN=64
CHANTYPES=#
CHARSET=ascii
ELIST=MU
EXCEPTS=e
EXTBAN=,ABCNOQRSTUcmpr
FNC KICKLEN=255
MAP are supported by this server
MAXBANS=60
MAXCHANNELS=20
MAXPARA=32
MAXTARGETS=20
MODES=20
NAMESX NETWORK=GlobalIRC
NICKLEN=31
OPERLOG OVERRIDE PREFIX=(qaohv)~&@%+
SECURELIST
SSL are supported by this server
STARTTLS
STATUSMSG = ~ & @ % +
TOPICLEN=307
USERIP
VBANLIST
WALLCHOPS
WALLVOICES
WATCH=32 are supported by this server


I Server di GlobalIRC

Varie - I Server di GlobalIRC

Non è possibile vedere i server che formano la rete di GlobalIRC con il comando /map oppure /link.

Una possibile rappresentazione della rete:

Esistono indirizzi detti round robin o hub che raggruppano vari server e indirizzano al primo disponibile:
Il round robin di GlobalIRC Network è: irc.globalirc.it

Le porte utilizzabili per la connessione sono normalmente 6666, 6667, 6668, 6669. La porta 6667 è quella standard.
Per le connessioni via SSL la porta da utilizzare è normalmente 6697

IPV6 e GlobalIRC

L' indirizzo IPv6 è ipv6.globalirc.it
La porta per IPv6 del server è 9999
Per connessioni sicure (SSL) con il protocollo IPV6 la porta è: 9997

È possible connettersi su GlobalIRC utilizzando una chat java dall’indirizzo:
http://javachat.globalirc.it/

oppure FlashChat:
http://flashchat.globalirc.it/

oppure MibbitChat:
http://mibbit.globalirc.it/

WebChat all'interno del nostro portale:
https://www.globalirc.it/#chat


Link Utili

Varie - Link Utili
Il sito Social di GlobalIRC 2.0
https://www.globalirc.it/

I regolamenti di GlobalIRC
https://www.globalirc.it/regolamento
https://www.globalirc.it/about
Link utili sul sito di GlobalIRC
Proposta Link Net/Server: https://www.globalforum.globalirc.it/Forum/viewforum.php?f=17&sid=2a82adb3d7c94d6b0a2f7d25113de98f
WebPanel: http://webpanel.globalirc.it:8080/
Altri link utili
FORUM: https://www.globalforum.globalirc.it/Forum/index.php
Statistiche del Network: http://stats.globalirc.it/stats/
Richieste di Bot e altro: https://www.globalforum.globalirc.it/Forum/viewforum.php?f=16&sid=2a82adb3d7c94d6b0a2f7d25113de98f